WordPress.org

Ready to get started?Download WordPress

Forums

Event Organiser
Conflict with W3 Total Cache (6 posts)

  1. schmaart
    Member
    Posted 2 years ago #

    Just to share with others...

    Full calendar was hanging on "Loading..."

    Deactivating the W3 Total Cache plugin immediately fixed this issue so I reactivated it and disabled various caching features one-by-one until the calendar worked.

    I found that disabling the "JS minify settings" allowed me to use both plugins together.

    http://wordpress.org/extend/plugins/event-organiser/

  2. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    Was there any console error when JS minified was enabled? I imagine that the compressed javascript is somehow invalid.

  3. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    Looking into this myself, I couldn't see any obvious errors - so my above assumption may be wrong. I've found these related threads which perhaps indicate that this a wider issue, and not specific to Event Organiser:

    As a side note, I try to keep the scripts (more or less) compressed anyway.

  4. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    Incidentally, I only get stuck 'Loading...' on the first visit after emptying the cache.

  5. Ian Anderson Gray
    Member
    Posted 2 years ago #

    Just wondering if there was any update on this? I am having the same issue.

  6. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    Not as yet. As far as I can tell this problem isn't specific to EO. Disabling the JS minify is the only 'solution' at the moment.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic