WordPress.org

Ready to get started?Download WordPress

Forums

Event Calendar / Scheduler
[resolved] Problem solved: Yellow loading bar (4 posts)

  1. Duncan
    Member
    Posted 2 years ago #

    In case you only find an ever loading, yellow status bar, go to the plugins folder at: wp-content/plugins/event-calendar-scheduler/codebase/iframes find row 216

    replace

    option.setAttribute('options', '<?xml version="1.0"?><rows></rows>');

    with

    option.setAttribute('options', '<' + '? xml version="1.0" ?' + '><rows></rows>');

    That should do.
    Frank

    http://wordpress.org/extend/plugins/event-calendar-scheduler/

  2. kenherr
    Member
    Posted 2 years ago #

    I found this line of code in the custom_fields.html file and changed it. That did not fix the problem of the constant yellow loading bar. Did I modify the correct file?

  3. Duncan
    Member
    Posted 2 years ago #

    Yes, that's the file.
    Sorry I forgot to mention it in the first place.

    wp-content/plugins/event-calendar-scheduler/codebase/iframes/custom_fields.html

    Well, in our case, the application came up with an PHP error message within the custom fields - so apparently custom_fields.html was the culprit. Allegedly, <?xml was parsed as php - so we just hacked it in peaces.

    Is there any error mentioned in your case? Try the following:

    1. Download the latest version of the Opera Browser. It has a very powerful tool built in to examine a page.

    2. Load your page

    3. Right click on the yellow loading bar and choose "inspect Element" (The Opera tool will open)

    4. On the left side of the tool, you'll find the html, on the right, the css. Just select the html for the yellow bar - the applied css shows up in the right window. Now look for the declaration that makes the button being 100% height, floating and absolute (I cannot remember perfectly anymore). Uncheck the mentioned declarations, so that the layer is gone - or at least not above your navigation.

    5. Close the inspection-tool (but NOT opera). The layer still should be gone now. So you can use the accordion menu - open each one to find the culprit. Once you found it, debug the code yourself or post the error message here.

    Kind regards from Creativtransfer,
    Frank

  4. kenherr
    Member
    Posted 2 years ago #

    I have found that the error only occurs in IE9. The Scheduler settings page loads fine in Chrome, FireFox and Opera.

    In IE9, I see this error:

    SCRIPT438: Object doesn't support property or method 'load'
    dhtmlx.js, line 22 character 226

    Here is the code that IE is highlighting:
    this.xmlDoc.load(filePath)

    I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic