WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] "You have not chosen a payment option" With Only One Selected Merchant Ga (6 posts)

  1. nwonderland
    Member
    Posted 3 years ago #

    I just downloaded eShop v6.0.1 last week. So far I love the plugin and it's easy to use and very customizable.

    My one problem is that I'm using only one merchant gateway, Authorize.net. At the Checkout form before I click "Proceed to Confirmation," Authorize.net shows up as an image in a

  2. , but there is no radio button. Therefore every time I click "Proceed to Confirmation," the message "* You have not chosen a payment option" appears. When I add a second merchant, like Paypal, the radio buttons appear and I can then select a payment option. I'd like to just have the one merchant, though. Is anyone having this issue? I'd appreciate any ideas or feedback.

    The URL is: http://www.oakcliffpeople.com/shopping-cart/checkout/
    The shop page is: http://www.oakcliffpeople.com/i-heart-oc/

    Thanks!

  • elfin
    Moderator
    Plugin Author

    Posted 3 years ago #

    works fine for me.
    There is a hidden input when there is just the one merchant gateway, which is on your page.

  • nwonderland
    Member
    Posted 3 years ago #

    Thanks for the quick reply, Rich. I guess it was just cache, but it works for me now too.

    However, now I've stumbled onto another problem. After I confirm my details, it tries to connect to Authorize.net and get this error message: (14) The referrer, relay response or receipt link URL is invalid. Is that something to do with eShop, or should I look into my Authorize.net account?

  • elfin
    Moderator
    Plugin Author

    Posted 3 years ago #

    I'd check your settings at authorize.net - eShop generates the links so they should be fine.

  • nwonderland
    Member
    Posted 3 years ago #

    Hi Rich,

    Last Friday, I set up a new API Login ID, Transaction Key, and MD5-Hash Phrase on Authorize.net. Even though it was giving me the same error message, I decided to give it 24 hour just in case. But now, it's still giving me that same error message, and I'm not sure what the problem is.

  • elfin
    Moderator
    Plugin Author

    Posted 3 years ago #

    Try deactivating all others plugins and test in the default twenty ten theme.

  • Topic Closed

    This topic has been closed to new replies.

    About this Plugin

    About this Topic

    Tags