WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] [closed] If you are stuck in Test mode, try this (8 posts)

  1. BayouBill
    Member
    Posted 2 years ago #

    If you are stuck in eShop Test mode and cannot find the Screen Options tab so you can get to 2 Column mode, try this:

    1. Create a *new* WordPress Admin user for your site, then log out, clear your browser's cache, and log in as the new user.

    2. Go to Settings > eShop and click Screen Options at the top-right corner of the screen under "Howdy...".

    3. Click "2" for Number of Columns.

    4. You should now see eShop Status on the right side of the screen, where you can change "Testing" to "Live".

    5. Click Save Changes.

    eShop should now be in Live mode, and you can now log out, log back in with your regular user name, and delete the new Admin user you set up in Step 1.

    This worked for me. The key to the whole thing was setting up a new Admin user as described in Step 1.

    Hope this helps.

    BayouBill

    http://wordpress.org/extend/plugins/eshop/

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. BayouBill
    Member
    Posted 2 years ago #

    Yes, step #6 at the quirm link you point to is now documented, but for quite a long time, when many, many people were asking how to solve this problem, there was just one lonely suggestion about that step from a user buried in one of the threads, and nothing from the moderators of the quirm site. That's why I posted it here.

    It would have been possible for the developers to solve the problem another way, and that would have been to move the settings to Column 1 in the 6.2.12 release so people wouldn't have had to try to figure out how to enable the 2-column display, but that was not done. That was another reason I posted what I did here.

    I'm sure you don't object to eShop users trying to help one another this way, even if they are duplicating your own efforts, right?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    nothing from the moderators of the quirm site.

    That's incorrect. That troubleshooting post was published as soon as we'd worked out a series of practical steps with eShop users and from our experience helping out here. Step 6 was actually suggested by a forum mod only recently and was added as soon as we had confirmation that it worked for some people.

    Prior to this, the steps that we did have were always given in our answers to individual users on the forum.

    It would have been possible for the developers to solve the problem another way

    That's currently not a practical option. As we have said repeatedly, this is not an eShop specific problem.

    I'm sure you don't object to eShop users trying to help one another this way

    Not at all but we would rather that they were pointed to the (pretty extensive & readily accessible) plugin documentation first.

  5. DerFichtl
    Member
    Posted 2 years ago #

    try to rename the status box in source code ...

    eshop-settings-extends.php ... line 870:

    add_meta_box('eshop-admin-1', __('eShop Status','eshop'), array(&$this, 'eadmin_box'), $this->pagehook, 'side', 'high');

    "eshop-admin" changed to "eshop-admin-1"

    or:
    the box in in html but via css hidden ... so you can also make it visible with firebug

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Please do not encourage people to hack the plugin. We will not support hacked versions of eShop. As I keep trying to say, this is not an eShop issue.

  7. mrjcgoodwin
    Member
    Posted 2 years ago #

    the box in in html but via css hidden ... so you can also make it visible with firebug

    I can confirm that this is the only way I found to solve this. I viewed the source in Chrome Developer tools (or Firebug would be the same). I then searched for 'eshop-admin' and found the line:

    <div id="eshop-admin" class="postbox hide-if-js" style="">

    In the style editor I then simply switched off the CSS style display:none for this element which allowed me to see the option to make the site live. Regardless of whether this is a jquery problem or not I find it odd that this element should ever need to be set to display:none or have jquery attached that would affect its visibility. Surely a simple display:block!important; in the plugin CSS should solve this bug?

    Great plugin otherwise!

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    It's NOT an eShop issue! How many more times do we have to repeat this? we cannot alter the CSS in eShop because it's not eShop's CSS that is causing the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags