WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] [closed] Good Orders stuck in Pending (Not going to Active) (22 posts)

  1. JenMadison
    Member
    Posted 1 year ago #

    Hi

    After updating the eshop plugin (to version 6.2.15), purchases are getting stuck in pending. (Using authorize.net as gateway). Is anyone else having that problem? Any solutions?

    Thanks,
    Jennifer

    ELFIN's REPLY:

    try reverting the [shipping] change, see if that resolves it for you.

    MY REPLY:

    Hi,

    Thanks so much for the suggestion Elfin.

    I reverted the change (removed the 2 new lines of code)and the orders are still staying stuck in pending (which seems to also result in no eshop email receipts sent and no transaction code generated). Before the last eshop update, using Authorize.net as the gateway, it was moving to Active and generating the proper emails.

    Any other ideas?

    Thanks again for your help.

    Best wishes,
    Jennifer

    http://wordpress.org/extend/plugins/eshop/

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Can you replicate the problem using the Twenty Eleven theme with all other plugins deactivated?

  3. JenMadison
    Member
    Posted 1 year ago #

    Hi Esmi,

    Thank you so much for getting back to me.

    My client just entered his busiest season and doesn't want me to shut the site down. He thinks I should wait to see if the problem still exists after the next update.

    It was working well before the last plugin update. Maybe it will work again after the next update.

    Thanks again for your help. Your plugin is awesome, and you guys do an incredible job dealing with the many WordPress challenges.

    Best wishes and many, many thanks,
    Jennifer

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    At the present time, we are not aware of any issues with eShop & Authorize.net but in order to confirm this, we really do need anyone who does have a problem to try and replicate it using the Twenty Eleven theme with all other plugins deactivated. Until the problem is replicable and we understand the circumstances needed to trigger any such bug, there is unlikely to be any change in the next update of eShop.

    Sorry :-(

  5. JenMadison
    Member
    Posted 1 year ago #

    Hi Esmi,

    I had a feeling. I am glad you shared this. I'll do my best to find a time when I can shut the site down. Hopefully Monday.

    Thanks again,
    Jen

  6. JenMadison
    Member
    Posted 1 year ago #

    HI Esmi,

    In order to check that the orders are moving out of Pending properly - do I need to be OUT of Maintenance Mode (meaning does the site have to be live to accurately test this part)?

    Best wishes,
    Jennifer

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Oh - yes! Absolutely!

  8. JenMadison
    Member
    Posted 1 year ago #

    Thanks. That's what I thought (but I was hoping I was wrong). I'll let you know how it goes.

  9. JenMadison
    Member
    Posted 1 year ago #

    Hi Esmi,

    I deactivated all the plugins except for eshop and changed the theme to 2011. And the orders still stayed in pending, and not generating the eshop emails.

    I hope this helps.

    Many Thanks and Best wishes,
    Jennifer

  10. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    if you are not getting emails from eShop then Authorize.net for whatever reason is not connecting to your site. You can test emails are being sent by choosing the cash merchant gateway and doing a test purchase with that.

  11. JenMadison
    Member
    Posted 1 year ago #

    Hi Esmi,

    I tested transactions with cash as the gateway, and the eshop emails did go through properly this way. And very importantly, the orders get a transaction code and go to the "Awaiting Payment" section.

    Also, authorize.net is the gateway that I am trying to get to work properly.

    I really hope this helps you see what the solution is.

    Best wishes and many thanks,
    Jennifer

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    All we can say is that you need to check your gateway settings in eShop and at the gateway site. Right now, it seems the two cannot communicate effectively.

  13. JenMadison
    Member
    Posted 1 year ago #

    Hi Esmi,

    The orders were moving properly from pending to active before the last eshop plugin upgrade - so I don't think it has anything to do with the settings I have for authorize.net.

    Is there any way for me to install the old plugin? Are the files available anywhere?

    Thanks,
    Jennifer

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    Sorry - we cannot support older versions of eShop. And the symptoms you describe are classic "gateway cannot contact site" ones.

  15. JenMadison
    Member
    Posted 1 year ago #

    Hi,

    Could we pay you to help us get things working properly with the new versions?

    I am not asking you to support older versions. Since the last version worked for us, I was wondering if there is a way I can re-install that.

    Thanks,
    Jen

  16. We generally close all requests/offers to pay for this stuff.

    But you can download older versions here: http://wordpress.org/extend/plugins/eshop/developers/

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    Could we pay you to help us get things working properly with the new versions?

    You would need to contact us directly. Discussing any paid work is not allowed on these forums.

    Since the last version worked for us, I was wondering if there is a way I can re-install that.

    The last version was updated to correct issues in the Authorize.net module. As you'll see in the plugin's dedicated forum, those issues now seem to be resolved and we're not seeing any further general problems with Authorize.net. Any site-specific problems will be caused by:

    - the current theme OR
    - any 1 or more other plugins OR
    - a mis-match between eShop's gateway settings and Authorize.net resulting in the Authorize.net not being able to contact your site.

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    you can download older versions here

    Just to reiterate - we don't support older versions of the plugin. We only support the most current version. Nor do we recommend downgrading to an earlier version as this may actually create more issues than it solves.

  19. JenMadison
    Member
    Posted 1 year ago #

    Hi,

    Thanks for getting back to me.

    Sorry about mentioning p..... for work. I did not know that and won't do that again on a WP forum.

    I looked through the other forum and from what I can see, it looks like other people are also having problems with orders going to active.

    I thought by trying the 2011 theme and deactivating all the other plugins, it made it clear the first 2 possible causes - are not the problem. And the fact that I did not change the authorize settings between updates and it was working before I updated the plugin eliminated that 3rd possible problem.

    I think we will cross our fingers and hope the next update somehow fixes it. If it doesn't, I'll contact you through the contact link.

    Thanks again for your time and help,
    Jen

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    it looks like other people are also having problems with orders going to active.

    Not general ones since the latest version was released. The users that we were working with on the previous version all confirmed that this fixed the issues in their cases.

  21. powderhigh
    Member
    Posted 1 year ago #

    Hi esmi,

    I'm using eshop for my website and the theme I'm using is by Catch Themes. I'm seeing the same problem in which the product inventory does not update. Even when authorize.net confirms that the payment went through, it still doesn't take the order out of "pending". Thoughts?

  22. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    powderhigh, please start a new thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags