WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] EMPTY CART ERROR (5 posts)

  1. aboarman
    Member
    Posted 3 years ago #

    Using WP 3.03, Weaver 2010 theme, Hosted on iPage. Edited php.ini so that register_globals = Off
    I have read through 100 forum posts trying to get some kind of answer as to whether this plugin will work or not. I just want to know - will it work with my current config, and if so, how? NO one seems to be able to give a definitive answer. If it's a hopeless case, then ok, whatever.
    Why is it so hard to find info on this? It seems like a lot of people have had the same problem.
    Thank you to whoever helps!
    Adam

  2. elfin
    Moderator
    Plugin Author

    Posted 3 years ago #

    If the cart stays empty then it may be a php session issue. But I'd always suggest changing to the default twenty ten theme, and deactivating all other plugins to test that there are no conflicts.

  3. aboarman
    Member
    Posted 3 years ago #

    Hi Rich -

    Thanks for the answer. I have no idea what a PHP session issue looks like. I have to have the weaver 2010 theme because it's a site for a corp client and there are things that I can only get with weaver. I don't have any other plugins active at the moment because it's a new build. I can't seem to find any shopping cart that works other than some crappy one that only supports Paypal. AHHHGGGHR!! ;-)

  4. elfin
    Moderator
    Plugin Author

    Posted 3 years ago #

    Try speaking to the web hosts then about php sessions not saving correctly - and see what they say.

  5. aboarman
    Member
    Posted 3 years ago #

    Rich - once again, thank you for your help. I figured it out using iPage's Knowledgebase on PHP, and, hopefully with your approval, will post step by step instructions here. I wish I had this 10 hours ago. Be well ;-)

    HOW TO GET eSHOP and OTHER PHP BASED PROGRAMS WORKING ON IPAGE. ENJOY.

    # Find your actual path

    1. Go to your Website >Server Information
    2. In the top section find the setting called Document Root

    Your path should be in the form /home/users/web1111/pr.username/dir where pr is an abbreviation for iPage, username is your hosting account username, and dir may be an additional directory such as public_html, or docroot, or root, or even empty.
    3. Copy this path, you will need it in the next step

    # If your DocumentRoot ends with /public_html or /htdocs, create a phpsessions directory as directed below:

    1. Using the FileManager, create a folder in the root directory, parallel to your DocumentRoot (from above). In FileManager, the document root is marked with a globe icon (see below)
    2. Call this folder phpsessions
    3. Your full path is your actual path to your root directory, which is DocumentRoot, minus the /public_html or /htdocs directory, plus phpsession. In the example above, your full path would be:

    /home/users/web/b556/pr.username/phpsessions
    where pr is an abbreviation for iPage and username is your hosting account username

    # If your DocumentRoot DOES NOT end with /public_html or /htdocs, determine the path to your cgi-bin/tmp directory as follows:

    1. Log into FileManager

    2. Find your document root directory (the one with a globe icon)
    3. Locate the tmp directory under cgi-bin directory, and note the path to this directory that appears at the top of the right pane. For example, in the case above, the path is: /cgi-bin/tmp
    4. Your full path is the DocumentRoot directory determined in step 1, and the path to the tmp directory, determined here. So, in the example above, the full path is:
    /home/users/web/b556/pr.username/cgi-bin/tmp where "pr" stands for iPage's abbreviation, and username is your hosting account username.

    # Edit your php.ini file to include the full path determined in the steps above

    1. Navigate to the PHP Scripting page, which contains your php.ini file from Scripting and Add Ons > CGI and Scripted Language Support > PHP Scripting

    2. Scroll to the bottom, and click Edit to edit your php.ini file
    3. Find the line where sessions.save_path is set

    4. Set the sessions.save_path to the full path determined above, for example:

    For DocumentRoot ending in /htdocs or /public_html:
    sessions.save_path = /home/users/web/b556/pr.username/public_html/phpsessions
    where pr is an abbreviation for iPage, username is your hosting account username, and /public_html could be /htdocs instead.

    For DocumentRoot NOT ending in /htdocs or /public_html:
    sessions.save_path = /home/users/web/b556/pr.username/cgi-bin/tmp
    where "pr" stands for iPage's abbreviation, and username is your hosting account username

    5. Click Save

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags