WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] Confirm Email sent from [blog_name] (11 posts)

  1. dezahn
    Member
    Posted 1 year ago #

    the email that gets sent to the customer comes from the code [blog_name] rather than the site it was sent from.

    example
    From: [blog_name] (noreply@example.org)

    this "blog_name" code shows up in the header of the email and in the "from" column of the recipients email.

    I am using the Automatic default email as the template to send to them and everything in the email comes through just fine.

    is there something i can do to get that to come from the "blog name" this way when the customer keeps the receipt it will be from the correct company.

    Thank you so much for your help. I really appreciate it.

    http://wordpress.org/extend/plugins/eshop/

  2. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    hmm, I'll check the code for that for the next release.

  3. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    these emails are coming through fine for me.

    on the wp-admin/options-general.php page, what is your site title set to? as that is what is being used.

    however, in case you are still having issues, I have added a filter so that you can change this to whatever you need. This will be in the next release.

  4. dezahn
    Member
    Posted 1 year ago #

    checked that and there is a site title in the settings page you mentioned. Not sure what is up...if another setting somewhere is messing with it or another plugin maybe????

    Thank you for all your help. I really appreciate it.

  5. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    I've added this filter: eshop_from_address for you to amend it.

  6. dezahn
    Member
    Posted 1 year ago #

    i did see that in the email templates area. Funny thing though. that part was working. the address was coming through just not the "website/blog name". so in your email under "From" it says [blog_name] and then the "Subject" is correct.

    then once you open the email the "header area" with the from address and such looks like this:

    From:[blog_name] <noreply@giftcollection.org>
    Subject: Cash awaiting payment -Completed Payment Ref:552300028503e411a3ae08
    Date: August 29, 2012 11:19:57 AM CDT
    To: example@example.com

    this one happens to be a sales report, but all the emails have the same thing happening.

    Thank you for keeping up on this and working on it.
    Have a great day

  7. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    sorry but I have no idea what you mean. The From address is correct, and looking at what you say you agree. Can you try just explaining where you are actually have this issue please.

  8. dezahn
    Member
    Posted 1 year ago #

    in the above information the "From:" address should not be [blog_name]

    shouldn't it be the name of my blog????

    so basically when your looking at the list of new emails you have it looks like this...for instance

    FROM Subject Date
    [blog_name] Your Order Receipt Today

    I hope that makes sense.
    I appreciate your attention on this.
    Thank you for all your help.

  9. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    so you actually see [blog_name] ? rather than the actual name of your blog?

  10. dezahn
    Member
    Posted 1 year ago #

    yes. that is the exact text that comes in.
    sorry thought we were on the same page with that.
    Thanks a bunch

  11. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    in that case i have no idea why it is happening, but with the filter I set up you can use that to set it to whatever you want, and that should then show correctly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic