WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Plugin Error (18 posts)

  1. egardner
    Member
    Posted 1 year ago #

    When Jet Pack is enabled, a few of my links have this at the top:

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/egardner/public_html/wp-includes/functions.php on line 658

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/egardner/public_html/wp-includes/functions.php on line 661

    http://wordpress.org/extend/plugins/jetpack/

  2. quirkylissy
    Member
    Posted 1 year ago #

    I am having this problem too, how did you resolve this?

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/wp-includes/functions.php on line 658

  3. egardner
    Member
    Posted 1 year ago #

    I isolated that the issue was stemming from Jetpack but didn't get much further until I found this article:
    http://sekarlangit.com/solve-wordpress-function-stripos-error.php

    I ended up deactivating the sharing module and installing a different sharing plugin (shareaholic) instead. Jetpack is still running, I just nixed the share module.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you send us a screenshot of the Settings > Sharing page in your dashboard? It might help us understand the issue.
    Thanks!

  5. egardner
    Member
    Posted 1 year ago #

    It didn't have to do with the general sharing settings, just those associated with the sharing module of jetpack.

  6. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    egardner: The Sharing settings page is the settings page for the Jetpack sharing module; it's possible that your specific sharing settings are the key to finding out why the error is occurring.

  7. egardner
    Member
    Posted 1 year ago #

    Okay, where should I send the dashboard screen shots?

  8. egardner
    Member
    Posted 1 year ago #

    That part of the plugin is currently deactivated so that I don't have the error warnings pop up on my links, so there is absolutely nothing about sharing in my settings, just publicize settings.

  9. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    Did you only disable the Sharing module, or do you have other Jetpack modules disabled?

  10. egardner
    Member
    Posted 1 year ago #

    Some of them are disabled because I just don't need/use them. Sharing is the only one I disabled recently.

  11. quirkylissy
    Member
    Posted 1 year ago #

    Just to update on how I resolved my problem (before egardner responded with her solution).

    I uninstalled Jetpack 2.0.4 and rolled back to earlier version of Jetpack 2.0.3; after which, it will prompt you to upgrade to latest 2.0.4. I did that and everything works fine after.

    Some other users feedback (sorry, I forgot where I saw, but it's one of the forum posts) similar issues and one proposed this, and it works for me.

  12. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    I believe that we've resolved the problem for the next version of Jetpack; details here: http://wordpress.org/support/topic/jetpack-youtube-embeds

  13. indirakrishna
    Member
    Posted 1 year ago #

    I posted the same some where else also But could not find a fix

    http://meet.indirakrishna.in/docs/create-and-manage-a-new-group-for-class-mates/

    I am getting a stripos error in docs

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/sitename/public_html/mysubdomain/wp-includes/functions.php on line 658

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/sitename/public_html/mysubdomain/wp-includes/functions.php on line 661

    Can any one help me with this ? I have tried in many forums but I did not find a resolving answer.

    WP Version 3.5
    LINUX HOSTING PHP VERSION 5.2.17

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I replied to your other posts here.

  15. slm_xd
    Member
    Posted 1 year ago #

    I'm having the same issue too in an empty website. The issue happens only with the mobile view: http://i.imgur.com/h1gMSG7.png

  16. slm_xd
    Member
    Posted 1 year ago #

    Hmmm. Another thought that might be the actual reason behind this. I have my blog in one folder, and the website pointing to another.
    actual folder: blahblah.com/blog
    website in at: http://www.blahblah.com

    And while authorizing with wordpress.com, it showed my website name as the actual folder location.

    Hope this helps debugging.

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @slm_xd Could you try the solutions offered here:
    http://wordpress.org/support/topic/getting-an-error-5?replies=9#post-3787833

  18. slm_xd
    Member
    Posted 1 year ago #

    Hmm. Actually I already moved the files back to the root and the problem is gone now. But thanks for our reply :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic