WordPress.org

Ready to get started?Download WordPress

Forums

EP Hashimage
[resolved] Plugin Triggered Fatal Error (11 posts)

  1. pvillella
    Member
    Posted 2 years ago #

    Plug in does not work at all. As soon as you try to activate it, the following message appears:
    Parse error: syntax error, unexpected ':' in /wp-content/plugins/ep-hashimage/hashimage.php on line 21

    http://wordpress.org/extend/plugins/ep-hashimage/

  2. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    you need a newer install of php. php less than 5.3 is not supported.

  3. Mattias
    Member
    Plugin Author

    Posted 2 years ago #

    resolved

  4. LDMartin1959
    Member
    Posted 1 year ago #

    Similar issue but perhaps a different cause (PHP 5.3 is indicated as the default for this site configuration):

    "Parse error: syntax error, unexpected ':' in /home/content/s/a/n/sanganis/html/wp-content/plugins/ep-hashimage/hashimage.php on line 26"

    EP Hashimage Version 2.3.3 using WordPress 3.4.1.

    Thank you.

  5. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi LDMartin1956

    I'm unable to reproduce your problem. If you could create a php info page end check exactly what PHP version your server/site is running.

  6. LDMartin1959
    Member
    Posted 1 year ago #

    Mattias, I did check the PHP version via the C-Panel and it is 5.3. Are you needing something more specific than that?

  7. fjallstrom
    Member
    Plugin Contributor

    Posted 1 year ago #

    hi @LDMartin1959

    even so, i'm fairly certain your not running php 5.3.
    can you put this row into a new file and run it on the same server?

    <?php phpinfo();?>

    this will tell you which version you are running.

  8. LDMartin1959
    Member
    Posted 1 year ago #

    Ok, I'll check it out today at work and let you know.

  9. LDMartin1959
    Member
    Posted 1 year ago #

    Full PHP version number being used: 5.3.13

  10. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    hi @LDMartin1959

    If your server is running PHP v5.3.13 as you say our plugin should work without any problem.

    That specific error you have is what you get when trying to install the plugin on a server not running PHP 5.3 or higher.

    I would recommend you to take contact with your hosting provider about this problem and ask them why you get this problem when, from what you say, the server is running PHP 5.3

  11. LDMartin1959
    Member
    Posted 1 year ago #

    Okay.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic