WordPress.org

Ready to get started?Download WordPress

Forums

EP Hashimage
[resolved] Just does not work (20 posts)

  1. iltrev
    Member
    Posted 2 years ago #

    Installed, copied and pasted the shortcode in a post, and the result are a couple of broken links.

    http://wordpress.org/extend/plugins/ep-hashimage/

  2. Earth People
    Member
    Plugin Contributor

    Posted 2 years ago #

    The plugin uses timthumb to re-size and cache the images. The config is per default set to save the cached files in the server system temporary directory (which is better for security).

    There are probably some sort of permission error with your system temp directory. Are you having other problems like uploading files? Are you running on a windows or linux server?

    You can change the cache directory yourself in the timthumb-config.php file in the plugin folder if you would like to use another cache folder.

    Please feel free ask if you have any more questions.

    // Mattias @ Earth People

  3. iltrev
    Member
    Posted 2 years ago #

    Hi and thanks for your reply.

    No, never had any problem with uploading. About a year of happy publishing on a Linux server, and lots of plugins tested and installed.

    Perhaps I will try with the workaround, but - just my two cents here - if this is a known behavior, maybe there should be an option in the configuration section, and not a "put your hands in the config file" thing.

    Meanwhile, I gave it another try, installing the plugin on a totally different environment (different domain on a different hosting): encountered exactly the same issue, i.e. a row of broken links and nothing else.

    In my humble opinion your plugin comes from a really good idea, but I think you should consider working around that temp folder thing...

  4. Earth People
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hmm, strange. I just tested the plugin on another WP site on another server without any problems at all. Using the latest version of WP without any other plugins or themes.

    Is it possible for you to provide a link to your site so that I can see what kind of "broken" links you get?

    If that is not possible, can you please test to copy the full url for the images and access them directly from your browser. What message do you get then? It feels more like it is the image that is broken than any link.

    / Mattias

  5. abiset
    Member
    Posted 2 years ago #

    Hi,
    I've encountered an error while activating the EP Hashimage plugin in my WP 3.3.1 site.

    The error stated:
    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ':' in /public_html/wp-content/plugins/ep-hashimage/hashimage.php on line 21

    Please advise.
    //abi

  6. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    php5.3 is a requirement. the plugin will fail on line 21 if your php version is older than this.

  7. mentallic
    Member
    Posted 2 years ago #

    I'm getting broken links or nothing at all. Lots of pics posted but nothing happening on my site.
    http://www.mentallic.co.uk

    help!

  8. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    hard to tell why it's not working on your hosting without seeing any error logs. there is huge update to the hashimage plugin coming soon though.

  9. mentallic
    Member
    Posted 2 years ago #

    no errors are coming up anywhere as far as I can see. Plugin updated today (is that the 'big one' or an older one I missed perhaps).

    pics are being posted using twitter
    https://twitter.com/#!/julian_hoffi/status/200657660016726016/photo/1 for example.
    Still nothing showing on my site.

    I am using the code [hashimage hashtag="mentallic" limit="5"]

    hosting has php5.3, I've gone to great lengths to ensure that so that I can use this plugin.

    what do I need to do to find you error logs?

  10. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    your mentallic picture shows up fine on my wordpress install, using the shortcode provided by your post above.

    if possible, could you send me the rendered source, or give the url to your site so i can have a look?

    btw, have you tried using it as a widget? just a thought, but if your theme doesn't doesn't use the_content() for some reason, the shortcode will not work.

  11. mentallic
    Member
    Posted 2 years ago #

    the url http://mentallic.co.uk/

    I'm using u-design wordpress theme
    http://themeforest.net/item/udesign-wordpress-theme/253220

    I'm using the widget on the front page and short code on another

    http://mentallic.co.uk/?page_id=13

  12. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    under settings->ep hashimage, would you mind checking that the value for async is "true" rather than "1"? on my test install this defaults to "true", but if you haven't touched it, and it is "1" - your php install is somewhat different and we'll need to apply a quick patch for the default settings.

    /peder

  13. mentallic
    Member
    Posted 2 years ago #

    fab, thats done it, thankyou! Yes it was set as '1'

  14. Earth People
    Member
    Plugin Contributor

    Posted 2 years ago #

    The plugin has now been updated with a fix forcing the async value to be true/false even if a 1 or 0 is given in the options field.

    If left empty it sets the value to true, which is the default value.

  15. somejerk
    Member
    Posted 2 years ago #

    Hi, I am attempting to install the plug-in and I am getting this error:

    Parse error: syntax error, unexpected ':' in /home/meljohn/public_html/sweetnoms.com/wp-content/plugins/ep-hashimage/hashimage.php on line 26

    Please let me know what I need to do to correct this, it seems like the plugin is quite brilliant!

  16. fjallstrom
    Member
    Plugin Contributor

    Posted 2 years ago #

    @somejerk it sounds like your hosting does use php 5.3 yet.

  17. ndenitto
    Member
    Posted 2 years ago #

    Hi guys: This plugin looks excellent! I'd love to use it.

    I'm having trouble getting it to work in a test environment, unfortunately. I'm getting no errors... just no display. Here's a link where it's in the template (just below the_content()) and I've also put the shortcode into the page's CMS section. Here's a link:

    http://dev.nightlabel.com/wp/?page_id=2

    Any help would be much appreciated. Thanks for sharing your talents!

  18. ndenitto
    Member
    Posted 2 years ago #

    Okay... interesting. I looked at what was being kicked out to the page, and it looked like even though async was set to 'true' in my back end, it was printing out as 'false' in the front end and not pics were being displayed. When I changed it to 'false' in the back end, it started working. Any ideas? Is this a write permissions issue? Would really love to use async if possible.

    Also, is there any sort of rate limiting ceiling I should be aware of? I'm sure that caching will help, but I read somewhere that twitter API is limited to 150 unique calls from a single IP per hour. Just curious!

    Thanks again for an awesome plugin.

  19. Mattias
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @ndenitto

    Thanks you for your feedback. I have just updated our plugin to version 2.3.2 thanks to it.

    This update solves the issue with async settings not been able to save as true and now the plugin render proper html code.

    When visiting your site I have no problem to see the images rendered via the shortcode so the template tag should work for you as well.

    About Twitter you are right, there are a limit of unique request per hour per IP, what exact value of that limit is, I don't know.

  20. Mattias
    Member
    Plugin Author

    Posted 2 years ago #

    resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic