WordPress.org

Ready to get started?Download WordPress

Forums

Enable Media Replace
upload date does not change (4 posts)

  1. chinola
    Member
    Posted 2 years ago #

    The upload date of the file does not change whether you choose "just replace" or "replace, use new file name..."

    I can see some rational for not changing it for the first option but it would seem useful at least for the second.

    There are several pdf's on a site that are updated several times a year, every year. It's helpful to have the date showing in the media library updated.

    Since I haven't seen anyone else mention this, it looks like I have a feature request and not a quirk.

    plugin has been working well through several versions and it's use has been intuitive for several users. thanks.

    http://wordpress.org/extend/plugins/enable-media-replace/

  2. Måns Jonasson
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    this sounds strange, since the file modification time is what I use to display the file upload date. If PHP reports back the correct file modification time, it should work just fine.

    Also, on my server, whether I choose "just replace" or "replace, use new filename" the date/time is updated instantly, so this most likely has something to do with a configuration on your end. Are you using some sort of page cache with WP?

  3. chinola
    Member
    Posted 2 years ago #

    i just installed the plugin on a different wordpress install on a different server. No caching plugins and switched back to default theme. It behaves the same way. I tried with different files and different file types. The only thing I haven't tried is with files uploaded for the first time after installing the plugin.

    The upload date that is displayed when I'm in the media library for the file does not change from the original upload date no matter which option I pick. If I look at the same file through ftp, it shows the correct date/time.

  4. rediris
    Member
    Posted 2 years ago #

    I'm having this exact same issue. There should at least be a way to edit/update the upload date, so that the file shows up at the top of the Media Library list.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic