WordPress.org

Ready to get started?Download WordPress

Forums

Email Users
[resolved] Not a valid e-mail address format (9 posts)

  1. dcclxi
    Member
    Posted 2 years ago #

    I have the latest version to date of Worpdress (3.4) and Email Users (4.3.1). The problem is: I cannot send e-mails to individuals.

    When I press the send button, I get the following error message: "The email address of the user you are trying to send mail to is not a valid email address format.". I've tried with one and two users.

    I tried what's suggested by this post [resolved] Email Users plug-in reporting some valid addresses as invalid., but it still doesn't help.

    When I dig in the code, it seems the e-mail address tested is actually empty. If I print out the $recipients array, the e-mail address is there though. Any idea?

    http://wordpress.org/extend/plugins/email-users/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    I am not sure if it is related but I just fixed a problem where some debug code was preventing email from being sent to users. I have spent about the last hour trying various combinations and cannot replicate what you are describing. Can you try 4.3.2 and let me know if it is still happening?

  3. dcclxi
    Member
    Posted 2 years ago #

    I've just installed it, same issue.
    I got to send an e-mail to one or more individuals, click on one, write up some text, click on send, and the error message appears.

  4. dcclxi
    Member
    Posted 2 years ago #

    In the above case, the sender (me) does receive a copy of the e-mail supposedly not sent though.

    I tried to send an e-mail to a group, it works. Two of the members of the group are the two "individuals" I've tried to send an e-mail though and got an error message.

  5. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    Any chance you can post a screen shot somewhere? Is there anything unusual about the email addresses which are not receiving email?

  6. dcclxi
    Member
    Posted 2 years ago #

    Ok. Is there an e-mail address I could send them to? That'd be easier.
    The addresses are plain normal (Gmail essentially).

  7. dcclxi
    Member
    Posted 2 years ago #

    I've retested it with version 4.3.3.

    I have one group of 2 admin: 1, 2. I have one group of 10 authors 3, 4, ..., 11, 12.
    In the above, I can only check whether 1, 3 and 4 get an e-mail or not. I tried A and B below, being logged on as user 1.

    A. Send an e-mail to author group. User 3 receives the e-mail, but not user 4.

    B. Send an e-mail to one individual (user 3). User 3 receives no e-mail. The plugin screen says: "The email address of the user you are trying to send mail to is not a valid email address format" (red box), and "No email has been sent to other users. This may be because no valid email addresses were found. (another red box).

    C. Send an e-mail to two individuals (users 3 and 4). Users 3 and 4 don't receive any e-mail. The plugin screen says: "email not valid email not valid" (this message is above the interface title "Send an Email to Individual Users"), and "No email has been sent to other users. This may be because no valid email addresses were found. (red box).

    In all A, B and C cases, user 1 got a copy of the e-mail sent.

    Both users 3 and 4 have Gmail addresses.

  8. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    You can send it to me using my Gmail account. It is the same username as here on WordPress.org at gmail.com. All of my testing has been with Gmail addresses as well.

  9. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    Fixed in version 4.3.4! Thanks for the help in chasing down the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic