WordPress.org

Ready to get started?Download WordPress

Forums

ELI's Related Posts Footer Links and Widget
[resolved] Nothing shows up for Widget (17 posts)

  1. TrishaM
    Member
    Posted 2 years ago #

    I just updated from version 1.2.03.14 to 1.2.04.05 and nothing will show up for the Widget, even though I have double- and triple-checked how it's set.

    So I downgraded back to 03.14 and it works perfectly.

    WP version is 3.3.1.

    http://wordpress.org/extend/plugins/spostarbust/

  2. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    What is your website URL?

    Would you be willing to upgrade again and either let me have a look or copy the HTML source code from the page that should be showing the widget?

    If you don't want to post it here you can email me directly at:
    wordpress at ieonly dot com

    Aloha, Eli

  3. TrishaM
    Member
    Posted 2 years ago #

    Hi Eli - thanks for the prompt response - I will email you directly with a link so you can see it working, then after you see it I'll upgrade again and let you refresh the page to see that it doesn't work.

    For the benefit of anyone else who might have this problem, I'll post updates from our emails, but here's how I have it set up:

    I need the list of related posts to appear in the page, not the sidebar, so I added another sidebar widget area in the functions.php, and then created a custom page template that sets up the place for the widget.

    I also added some code to the functions.php that lets me add a Tag to Pages.

    In the previous version of the plugin, it worked perfectly - all posts that are tagged with the same Tag as the page show up fine.

    However, with the new version, the list of Posts don't show up, but in the source code it just has the section of comments from your plugin.

  4. pvgool
    Member
    Posted 2 years ago #

    I have the same problem after upgrade.
    Related links are shown at the bottom of posts when I set "add links to Related Posts at the bottom of every Post?" to yes.
    But they are not shown in teh widget area. Not when I set the above option to yes and not when I set it to no.

  5. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    pvgool,

    can I take a look at your site?

    If you don't want to post your URL here just email it to me at:
    wordpress at ieonly dot com

    Thanks, Eli

  6. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    Trisha,

    Thanks for letting me into your site. I must say I am impressed with how you have customized your site to get it to work with my plugin in an unintended way.

    I fixed it for you by manually downgrading one small section of code to the way I had it in the old version. This is only a temporary workaround as I see it. I have to drop this bit of code because it was causing conflicts with other plugins and theme. However, in your particular case, with your unique modifications you need this code to generate a query that my plugin can "Relate" to.

    The code I put back was:

    wp_reset_query();
    query_posts($wp_query->query);

    don't forget that $wp_query has to be a global if used in a funtion:
    global $wp_query;

    This code needs to be run before the widget area is init'd. I will not be using this code in future version of this plugin so I would suggest adding it to your other customization so that you can upgrade my plugin in the future.

    Aloha, Eli

  7. TrishaM
    Member
    Posted 2 years ago #

    Thanks Eli, I'll modify my custom template to call that before the widget area is initialized.

    I really appreciate your prompt response on this. All in all it's a great plugin and I'll rate it as such.

  8. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    pvgool,

    Thanks for sending me a link to your site. I have looked at the source code and explored your site and found that there is nothing wrong. I wrote my plugin so that it would not duplicate links and so there is no need to display the widget at this time as all the links needed are already being printed in the post foot by enabling that Automatic feature. The widget will show up as soon as there is a related post to link to that is not already listed.

    Aloha, Eli

  9. pvgool
    Member
    Posted 2 years ago #

    Eli, thanks for the support.
    I changed
    "Automatically add links to Related Posts at the bottom of every Post?" to no (Use this setting if you plan to use the Widget)
    now the related links are not being shown at the bottom of a post, and nowhere else on the page, but the widget still does not show.
    The widget did work under the previous version of the plugin.

  10. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    pvgool,

    Thanks for helping me find this bug. I just released version 1.2.04.07 with the fix that you confirmed works on your site. Please feel free to upgrade to the new version to make sure it is as the patch I sent you.

    If it works for you please vote "works" at: http://wordpress.org/extend/plugins/spostarbust/stats/

    Aloha, Eli

  11. pvgool
    Member
    Posted 2 years ago #

    Eli, it works.
    Thanks for your fantastic and super fast response.

  12. jennavery42
    Member
    Posted 2 years ago #

    Eli, I'm suddenly seeing related post links at the bottom of my pages. I don't remember seeing them there before. I love having them on my posts but I don't want them on my pages.

    You can see an example here:

    http://jennaavery.com/workwithjenna

    Thanks!

    Jenna

  13. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, I had removed the filter that prevented Related Posts from showing on Pages because some people wanted to use it for Pages as well as Posts. But I suppose the door swings both ways.

    I have just released an updated version 1.2.04.18 with an optional setting for showing on Pages or not.

    Please download this new version and let me know if this resolves your issue.

    Aloha, Eli

  14. jennavery42
    Member
    Posted 2 years ago #

    Eli, it worked! Thank you so much for the tweak. Jenna

  15. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    Sure, Thanks for making the suggestion.

    If you have time and like my plugin please rate it "Five Stars" and vote "works" at: http://wordpress.org/extend/plugins/spostarbust/stats/

    Aloha, Eli

  16. jennavery42
    Member
    Posted 2 years ago #

    Did! And donated. Great plugin. Thank you so much for creating it and for your super prompt support and help.

  17. Eli
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic