WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Elastic Theme Editor] json error (16 posts)

  1. tanc
    Member
    Posted 4 years ago #

    I've installed the elastic editor to try it out, and upon trying to run the editor I get:

    Fatal error: Cannot redeclare class services_json in /public_html/wp-includes/class-json.php on line 0

    I've disabled all other plugins apart from akismet to try to eliminate them, but still getting error. Do I need to physically delete them?

    Thanks

    Matt

    http://wordpress.org/extend/plugins/elastic-theme-editor/

  2. waltkania
    Member
    Posted 4 years ago #

    Exact same issue here. Except mine specifies line 115.

    Fatal error: Cannot redeclare class services_json in /home/content/w/a/l/waltkania/html/wp-includes/class-json.php on line 115

    Elastic sounds like a killer idea. If only I could get it to work. Is there a fix for this?

  3. tanc
    Member
    Posted 4 years ago #

    I've just tried it on a completely fresh install of 2.9 and get the same error...

    Nothing else installed (ever) on this installation...

  4. veehikle
    Member
    Posted 4 years ago #

    Have a few blogs. Getting the same:
    Fatal error: Cannot redeclare class services_json in /home/content/.../wp-includes/class-json.php on line 115

    And sure, my bad. And I was so excited to get the new uninstall feature. Problem is....I can't get v2.9 to work correctly. It's affecting existing posts and preventing editing. Also did mess up Google Analytics and Feeds. Not very Google friendly at this point.

    Dev problem for sure!

    Can you say v.2.9.1?

  5. ronbme
    Member
    Posted 4 years ago #

    tanc,

    Your problem is a conflict between the json.php file in the Elastic plugin directory and the class-json.php file in the wp-includes directory.

    Disabling plugins isn't going to help.

    I'm not the developer but this is a great little plugin. I've got it working on a Windows server and on a WAMP server locally, using WP 2.86 and WP 2.9.

    One problem was with the correct directories not being found. I've notified Daryl (the developer) and he is fixing this.

    I think you'll like what you see when you have this up and running. Like anything that is cutting edge, there will be always be little bugs to work out with different server combinations.

    Ron

  6. ronbme
    Member
    Posted 4 years ago #

    waltkania and veehikle,

    Your problem is the same as tanc's. This plugin does work under WP 2.86 and WP 2.9. The developer is working on it.

    There is also a potential problem some people may have with an extension on their servers. I'm working on this to confirm it.

    Ron

  7. Daryl Koopersmith
    WordPress Dev
    Posted 4 years ago #

    First, a thanks to Ron for all his help. Second, I'll hop right on making the proper checks for the JSON class. My apologies!

    —Daryl

    Update: Scratch that, Elastic is making the proper checks. WP added JSON support to 2.9, and I'll try and figure out where the definitions are conflicting.

  8. waltkania
    Member
    Posted 4 years ago #

    Thanks Daryl and Ron.

    This is such a killer idea, I'm itching to try it.

  9. tanc
    Member
    Posted 4 years ago #

    I've just tried under 2.86 and it does work under that, so having a play on a test installation, but definitely not under 2.9 (well without modification anyway!!)

    Thanks for investigating. Liking what I see so far!!

  10. GeekWhiteNorth
    Member
    Posted 4 years ago #

    Hi I found this issue post because I also had the same error---
    Fatal error: Cannot redeclare class services_json in /home/content/---my path---/wp-includes/class-json.php on line 115

    I now just got this working, This may be some help to others to troubleshoot their issue too.

    1) I was looking at the WordPress site and it says somewhere that whilst WordPress supports 4.3 there will be a time in the future where you will need to change to php 5.x. It also says that some things that do not work under 4.3 simply work under php 5.x -so iI thought I would give it a go
    There are a few cautions to changing to php5 but would only impact for a few people.
    There are instructions on how to do it with various host providers.
    I had to wait a few hours for the changes to filter though and once the system had changed. When I clicked to start it I no longer got the error message.

    2) Once working I was then able to move and resize things.
    However the boxes would not delete and the boxes would only resize once and the whole thing would not save. I was using Firefox 3.5
    I noticed a message suggesting some issues with browsers so I switched to Chrome browser where I can say everything now saves and can be resized multiple times.I also get the editor now.

    version of wordpress is 2.9
    Hope all that helps troubleshoot this issue.

  11. waltkania
    Member
    Posted 4 years ago #

    I think php 5.x is the key.

    Installed Elastic on a new blog with 2.9 and php 5.x. It seems to work just fine.

    It's a brilliant tool.

  12. robertsharp
    Member
    Posted 4 years ago #

    Erm, correct me if I'm wrong, but since WordPress specifies only PHP 4.3, isn't designing a plugin that only works with PHP 5.x something of a FAIL?

    I've heard great things about Elastic but I'm getting the error complained about above. Can someone recommend either
    a) A hack to the code to stop this error appearing; or
    b) A link to an earlier version of the plugin that works with WP 2.9.1 and PHP 4.3?

    Thanks,

    Rob

  13. flufftronix
    Member
    Posted 4 years ago #

    If you want to talk about fail, PHP 4 was deprecated in 2007..

  14. Daryl Koopersmith
    WordPress Dev
    Posted 4 years ago #

    Hi everyone,

    This bug will be fixed in the next release, which will become available later this week.

    WP 2.9.x now includes a file to simulate PHP's json functions. Elastic included a similar file that caused conflicts with WP's new file. Ironically, this bug exists because Elastic is designed to be compatible with PHP 4.3+. Once the update is released, please let me know if you still encounter errors.

    Thanks for the feedback,
    Daryl (Elastic developer)

  15. simoneqdm
    Member
    Posted 4 years ago #

    I also got this error but there was no evidence of elastic being on the site. But thanks to this post: http://niklasblog.com/?p=4253 I tried deactivating 'tweet blender'. Which seemed to work.

  16. Emilian Robert Vicol
    Member
    Posted 3 years ago #

    Most ilogical plugin see in my life ... was so difficult to work with menus in a logical manner to human thinking?

Topic Closed

This topic has been closed to new replies.

About this Topic