WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Calendar
[resolved] Quick edit deletes content after more tag (3 posts)

  1. Rob
    Member
    Posted 3 years ago #

    I have just used the plugin for the first time moving a couple of scheduled posts to different days and editing the scheduled times using the quick edit option.

    To my horror I went into the full edit screen and my entire post after the more tag I'd added has been deleted! The same thing has happened with all three of them. So much work has gone just like that. I have opening paragraphs for all 3 posts.

    If this is unrelated to any other plugins it is a serious bug and the plugin should be removed until fixed. A simple edit of the time and the post is lost!

    After all the good press about this plugin I am so hacked off.

    http://wordpress.org/extend/plugins/editorial-calendar/

  2. Zack Grossbart
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Rob,

    That just sucks. We hadn't tested enough with the more tag. What happens is that the quick edit only gets your post up to that tag and then when you save you lose the rest of it. We're really sorry this happened.

    The good news is that you didn't lose any data. WordPress saves each revision of your post. Just scroll to the bottom of the full edit page and you can see them.

    The better news is that we've fixed the problem. We've released version 1.3.2 of the WordPress Editorial Calendar and we are now showing the full content of the post in the Quick Edit dialog and not losing any data.

    The new version of the calendar has also added extra unit tests to make sure this never happens again.

    We hope you give the calendar another chance. We're trying to live up to all the great press we've received.

    Thank you,
    Zack

  3. Rob
    Member
    Posted 3 years ago #

    Hi, thanks for your quick response. And the quick plugin update! So glad it's fixed. Will look forward to using the plugin now.

    Like a fool I had forgotten about the revisions! I have a scheduled backup running every day and had picked out the HTML from a SQL file rather than importing the whole thing. Using the revisions was slightly easier!

    Thanks again. Issue resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic