WordPress.org

Ready to get started?Download WordPress

Forums

Edit Flow
[resolved] Version 0.7.1 of this plugin NOT compatible w/ PHP v5.4x (6 posts)

  1. Kilgore
    Member
    Posted 1 year ago #

    “Call-time pass-by-reference” has been depreciated in PHP for some time, and only generated lots of PHP warnings... but on PHP v5.4 and above, it throws fatal errors, preventing any WP page, including wp-admin pages, from loading at all.

    I discovered the hard-way that Edit Flow v0.7.1 is using “Call-time pass-by-reference” and will bring down WP sites on PHP v5.4 and above upon activation.

    It is a simple fix for plugin developers referenced here.

    I look forward to using this plugin once again, if/when it is updated.
    Thanks!

    http://wordpress.org/extend/plugins/edit-flow/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

  3. carpe annum
    Member
    Posted 1 year ago #

    Hi - I'm new to WordPress (migrating from Drupal) and am interested in this plug-in. Should I wait for the next release (v0.7.2?) before installing? It sounds as though the current version could crash my WPv3.4 site. Thanks, sorry for the noob post.

  4. Kilgore
    Member
    Posted 1 year ago #

    The problem I mentioned is with the plugin on PHP v5.4 and above, not a specific WordPress version (although we were using it on WP v3.3.3, so I can't say from experience that it's problem-free on WP v3.4 with < PHP v5.4, but I would not expect to see any problems).

    If your app server is running PHP v5.4 or higher, then definitely wait for the fix. If you are running < PHP v5.4, I know of no reason to wait.

    How to find your PHP version? Write a one-line php file, info.php:
    `<?php phpinfo();?>
    put it on your website and hit it with your browser, and it will display just about everything about your PHP install, including the version. Just be sure to promptly delete the file when you are done so nobody else can see your 'digital underwear' ;o)

  5. carpe annum
    Member
    Posted 1 year ago #

    Yes, so your said! In retrospect, a silly question so thanks for your patience. :-)

    Thanks for the PHP code - BlueHost (I assume that's my app server, but confess that I know pretty much nothing about the installation) is at 5.2.17, so I'm behind the times. Looking forward to trying out the calendar.

    Also, thanks for answering so quickly.

  6. Kilgore
    Member
    Posted 1 year ago #

    Thanks carpe, 'glad this was helpful.

    Actually, BlueHost is your hosting provider. The "app server" is the Linux or Windows machine on which your website resides. Similar to the term "web server", but "app server" usually means a web server with the ability to support real web applications like WordPress/Drupal/Jooma, rather than just serving up static web pages.

    Sometimes being behind the times is not a bad thing -- always upgrading to the latest release of anything without careful testing can be a real disaster, especially in an environment with so many "moving parts" as WordPress. PHP 5.2 is a nice stable release, so I'd be fine with that (hopefully your hosting provider will give ample warning before doing any major version upgrades).

    Good luck, and always keep asking questions -- it won't be long before you'll be providing answers ;0)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic