WordPress.org

Ready to get started?Download WordPress

Forums

Edit Flow
Save button (6 posts)

  1. mfraley
    Member
    Posted 2 years ago #

    When I enable the button under publish says save rather than "save draft". If I click the save button the post simply disappears. I have found out that the post does get saved to the db but as an auto-draft, so you can't get at it in the admin to edit it or change status etc.

    Right below the button show "Status: Draft", but the button doesn't reflect that. If I edit the status and select draft and hit OK, the button does change to "Save Draft", and then it will save just fine.

    If someone forgets to do this step they can loose a lot of work. Shouldn't that button default to "Save Draft"?

    If I disable the custom statuses module in edit flow, the button defaults to "Save Draft" and works as expected.

    http://wordpress.org/extend/plugins/edit-flow/

  2. mfraley
    Member
    Posted 2 years ago #

    Sorry, I should have reread my message before posting. I must have been distracted because some parts aren't very clear. I think you get the gist though. Let me know if you have questions or it need clarification.

  3. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    This is odd. Have you changed your custom statuses at all? Can you share some screenshots of what you see before and after?

  4. Dirty Bill
    Member
    Posted 2 years ago #

    Same problem here. The Save button shows up in full screen edit, but NOT in standard edit mode. Happened with the update.

  5. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    @Dirty Bill Can you share some screenshots of what you see? Does the problem persist after you deactivate all other plugins? Any Javascript errors you notice?

  6. Dirty Bill
    Member
    Posted 2 years ago #

    The problem doesn't persist if I deactivate Edit Flow. Here is an image from one of our editors: https://www.facebook.com/photo.php?fbid=10151029373697779&set=o.238106879581642&type=1&theater

    I've been using Edit Flow for a couple of years, our plugin structure has remained static for over a year, it broke with the last edit flow update.

    Note: No users are able to publish to live, they can only submit for approval then our managing editor will do final edits before pushing it live.

    Before diving into that being the out - this workflow has been working fine for a long time and ONLY broke with the Edit Flow update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic