WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] Error Uploading (24 posts)

  1. jamesdonegan
    Member
    Posted 1 year ago #

    I created an Edge composition that works just fine when I run the HTML file in Safari (locally from my harddrive), but when I upload the .zip file, I get the following message:

    Aborting, no file found that matches the main edge JS filename pattern. This is not a valid composition archive.

    ...then, under the page title...

    The file HomeAnim_5.zip has been uploaded.

    Errors occurred while creating the uploaded project. The import was most likely corrupted.

    http://wordpress.org/extend/plugins/edge-suite/

  2. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    this basically means edge suite was not able to locate the projectname_edge.js file within the zip. Which preview version are you using?

    Would you mind uploading the zip somewhere, then I could check what's going wrong.

    Thanks for testing, Timm

  3. jamesdonegan
    Member
    Posted 1 year ago #

    Good morning. Thank you for responding!

    I'm using Edge 0.11.0

    I am not sure how to get you the file (tried uploading it to my FTP server for the site, but WordPress is trying to make it a page).

    Here's the link to a Dropbox folder. I think it'll work for you. If not, just send me your e-mail address, and I'll authorize you.

    https://www.dropbox.com/sh/kwzv8m4jdwgl5f5/6OcvlaQ2ac

    I've included the unzipped file (HomeAnimation) as well as two .zip files: one that's the un-optimized files and one that's the "published" version. Neither works, but since I'm not sure exactly what Edge does to optimize, I figured I'd include both.

    THANK YOU for your help!

  4. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I just tested both zips on my installation and all works fine. I guess it has to do with file permissons. Can you check if /wp-content/uploads/edge_suite exists and is writable? Where are you hosting your site?

  5. jamesdonegan
    Member
    Posted 1 year ago #

    It does exist. Permissions set to 777. I couldn't change permissions for the subfolders.

    Still getting the same error.

    I actually don't know where the site is hosted. I'm a freelance designer/illustrator/reluctant developer, so it's wherever the client has been hosting their site. I even tried uninstalling/re-installing the plugin. Same error.

    I also tried deactivating all of the other plugins. Same error.

  6. jamesdonegan
    Member
    Posted 1 year ago #

    The site I'm working on: http://staging.m6d.com

  7. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, that is a bit strange. What directories are in the edge_suite directory? Is there an edge_tmp directory witch contains another directory like src_xxxxxxx (xxxx being a random number)?

    This is a bit strange because extracting the zip file doesn't seem to throw an error, so the above mentioned directory should be there, but then the files should be found on the server as well. If that's really the case then I would add a new log message to be sure what's happening.

    You could also try to install the "Error Log Dashboard Widget" to check if wordpress logs any error messages. The domain seems to be registered through godaddy so chances are good it's also being hosted there. From what I got godaddy can sometimes be a bit tricky.

  8. jamesdonegan
    Member
    Posted 1 year ago #

    That directory is there, and there are tons of src_xxxxxx files -- from all my failed attempts, I guess.

    So the files are getting there. It's this error that causes me the most concern. Maybe it shouldn't:
    "Aborting, no file found that matches the main edge JS filename pattern. This is not a valid composition archive."

  9. jamesdonegan
    Member
    Posted 1 year ago #

    I don't know how to add a new log message -- beyond my technical expertise -- but I installed the Error Log Dashboard Widget, and it appears that the only errors are actually in that widget.... I'm pasting below.

    Warning: fopen(error_log) [function.fopen]: failed to open stream: No such file or directory in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 115

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 117

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 123

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 124

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 129

    Warning: fread(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 130

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 132

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 143

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 145

    Warning: fclose(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 148

  10. jamesdonegan
    Member
    Posted 1 year ago #

    I added a screen grab of the directory in the Dropbox folder. I think everything is in order.

    Ugh.

    I'm sure you made a great platform. I wish something wasn't f*ing it up. :)

  11. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Uhh, ok, lot of folders. You can delete all of them if you want. I have to check, in general folders should be deleted if something goes wrong. Have to check up on that. But the folders src_xxxx contain the files that are in the zip? Just making sure those are not empty.
    I'll try to check up on the code and push an update later on so we have a better clue about what's going wrong.

    The error widget doesn't seem to be able to use fopen, that's kind of common, so forget about the widget.

  12. jamesdonegan
    Member
    Posted 1 year ago #

    I agree. It won't let me delete them, and it won't let me change their permissions.

    The folders are empty.

    Thanks for your help. I'm taking a lunch break. :)

  13. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Did the edge_suite folder have permission 777 right form the start or did you change that manually. What about the permissions for edge_tmp and project, 777? And the src_xxxx folders? If they don't have 777 try to set it (through edge_suite and option recursive or on each folder manually) and then again try to delete them.

    I think we might be getting closer. It looks like edge suite is able to create folders but can't delete them or add any files.

  14. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I changed how directories are created and added some writable tests. Maybe that fixes it. I would recommend deactivating the plugin, deleting it and all the directories with it and then install the new version.

    This is not a live site you are working on right? This would be really risky as this plugin is not meant for production at all yet.

  15. jamesdonegan
    Member
    Posted 1 year ago #

    Thanks. I'm unable to delete the upload/edge-suite files (not sure why -- even in Dreamweaver, which I'm using as my FTP client in this case). Regardless, I downloaded the new version, uninstalled the old one, and installed the new one... and the same result.

    I guess this just isn't gonna' work. Ugh.

    Thank you for your help.

  16. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    I guess if the directories are not deleted they won't be recreated and therefore permission will not be changed.

    Are you able to change permissions to 777 for the files that you can't delete? Otherwise try to rename the edge-suite directory. That would at least be a tmp solution and you could try the new version. Would be really interesting to know which hoster this is, seems to be quiet restrictive.

  17. jamesdonegan
    Member
    Posted 1 year ago #

    The folders are set to 777, but it won't let me do anything to the src_ folders or the clean_ folders .... can't delete, rename or change permissions. Crazy.

    But I changed the name of the uploads/edge-suite folder and tried to upload a new .zip file. Here's what happened:

    1. Same exact error as before
    2. The plugin created a new uploads/edge-suite folder
    3. Created a src-#### folder
    4. That folder is empty, and I can't delete or make any changes to it

    I'm going to try this: http://www.oddodesign.com/2011/adding-adobe-edge-animation-to-your-wordpress-website/

  18. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Permissions are tricky, I guess the apache is not even in the same group as your ftp user. Not sure what is going wrong though, messages should be output. It's really hard for me to debug this when not having the actual server at hand, sorry. Maybe someone else comes across the same problem and we can solve it there. I'll let you know in case I work something out.

  19. jamesdonegan
    Member
    Posted 1 year ago #

    Thanks. The other guy's page didn't work, either. I think it was for an earlier release. I'm getting a lot of egg on my face, here, because I told my client I could deliver it without an issue.

    Oh, well. Not much I can do that I haven't tried. On to bigger fish... (Well... to other fish...)

    Thank you for your time.

  20. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    so I finally figured out what went wrong. I was using wordpress' filesystem API which seemed quiet handy. Turns out it's a bit complicated because it works with different file methods depending on the server (direct, ftp, ssh,..). I'm pretty sure what happen in your case was that the methods got all mixed up as direct access was probably not fully possible. For now I made the system consistent and just used direct access, FTP will follow soon.
    Maybe you don't mind testing again. You just need to upload the new version of the module, it should then work as expected. If you want to get rid of all the empty folders you can activate "Deactivation deletion" in the global settings and then deactivate and activate the plugin again. When the option is set the plugin will clear out all files, folders and the database when deactivating the plugin.

  21. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    as this seems to work for lot of people with the updated version I'm marking this as resolved. Feel free to open it up again in case there are more problems.

  22. Zbert
    Member
    Posted 1 year ago #

    Hi, I was just trying out your Plug-in for the first time today and came across this same error when I tried to upload my oam file: "Aborting, no file found that matches the main edge JS filename pattern. This is not a valid composition archive."

    I went through and made sure that the permissions were all set to 777 for every folder in the "edge_suite" folder as well as changed the max upload size to 10mb in the settings area and still the same error.

    Sorry to bring this error up again, but any help would be great.
    Thanks,
    Kevin

  23. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Kevin,

    are any subdirectories being created?

    Did you try the dev version? http://downloads.wordpress.org/plugin/edge-suite.zip

    If you keep having troubles please open up a new ticket, the existing ones are already a bit messy, easier to keep track if you open up a new one.

    Thanks, Timm

  24. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    just had another idea. How big is the OAM that you want to upload? If it's quiet big, can you try a smaller one. I have just added some code to check the max filesize the server supports. It's on the settings page below the max filesize option. The option is meant to limit the filesize through the plugin, but it is also restricted through the server. It could be that the max upload filesize of the server is 5M or so on some hosters.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.