WordPress.org

Ready to get started?Download WordPress

Forums

Ecwid Shopping Cart
Does not work with HeadSpace2 plugin (8 posts)

  1. solutionsphp
    Member
    Posted 2 years ago #

    Store page is blank if HeadSpace2 SEO plugin is enabled. JS conflict.

    http://wordpress.org/extend/plugins/ecwid-shopping-cart/

  2. Ecwid
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    Thank you for the report. We're investigating.

  3. Ecwid
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    We've checked Ecwid with HeadSpace2. We've installed both plugins and enabled all HeadSpace2's settings. Then we opened the store page and Ecwid loaded properly, without any issues.
    So, could you please provide some more information?
    - What WP theme do you use?
    - What HeadSpace2's settings does your "Store" page have?

  4. solutionsphp
    Member
    Posted 2 years ago #

    Thank you for looking into this. I'm using a custom theme that's a child theme of twentyten. I disabled all other plugins when testing, and it was switching HeadSpace2 on and off that made the difference of the store page loading or not. Given that you couldn't replicate this though, it sounds like some other variable in my setup is what triggered the problem. I went for the quick remedy and switched from HeadSpace2 to the Yoast WP SEO plugin, so I no longer have the HeadSpace2 settings to provide you. HeadSpace2 is pretty popular so if no one else is reporting issues, we can probably mark this as resolved. Thanks again!

  5. Ecwid
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the information! We will try to reproduce the problem once again, maybe a specific combination of settings causes the issue.

  6. solutionsphp
    Member
    Posted 2 years ago #

    I solved this problem by switching to the Yoast SEO plugin but have now learned through the Ecwid forums that this plugin negatively interacts with Ecwid, by setting an "incorrect" canonical URL preventing indexing of the store.

    Since I use HeadSpace2 on all my other sites and would prefer to use it over All In One SEO, I disabled Yoast SEO and re-enabled HeadSpace2 just to see if I could get it working. Unfortunately the same problem happens: blank Ecwid store with HeadSpace2 enabled.

    I haven't tried this with a clean WP install and no other plugins, so the problem must be a combination of settings and plugins, as you said.

    Off to install All In One SEO... I hope this plugin "plays nice" with Ecwid!

  7. Ecwid
    Member
    Plugin Author

    Posted 2 years ago #

    I solved this problem by switching to the Yoast SEO plugin but have now learned through the Ecwid forums that this plugin negatively interacts with Ecwid, by setting an "incorrect" canonical URL preventing indexing of the store.

    Hi,
    Actually, the Yoast plug-in can be slightly modified to fix the canonical URL issue with Ecwid. Please, post a message in the thread on the Ecwid forums and we will help you to modify it.

  8. solutionsphp
    Member
    Posted 2 years ago #

    I wound up modifying Yoast's WordPress SEO, maybe using the same method as is suggested in the Ecwid forums: I disabled canonical URL support in it. (I stuck with Yoast's plugin because I couldn't find a way to export the settings to All In One SEO.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic