WordPress.org

Ready to get started?Download WordPress

Forums

Easy Table
[resolved] Problem with 'Enclosure' + can't get CVS to table to work (13 posts)

  1. arjanvandenbos
    Member
    Posted 2 years ago #

    1) Wrapping cell data with commas in double-quotes does not work; every comma is still treated as a cell Delimeter.

    2) Can't get CVS file to table to work; ticked 'Allow read CSV from file?' in Easy Table settings, added shortcode like this (with my file details):
    [table file="example.com/blog/wp-content/uploads/pricelist.csv"][/table]
    But nothing happens at all

    Any ideas ?

    http://wordpress.org/extend/plugins/easy-table/

  2. takien
    Member
    Plugin Author

    Posted 2 years ago #

    first, Is your PHP version lower than 5.3.0? If so, I'm so sorry because I couldn't give full support if you're using PHP prior to 5.3.0.
    however, I will always try to resolve this issue.

    second, make sure you paste the right URL path, include http:// etc. test using browser to direct access to the file, if not found, probably it's wrong path.

    the last, check if you're using other table plugin that also use [table] short tag, I have not encountered this problem, but it never hurts to disable other table plugin or just change with another tag if necessary.

  3. arjanvandenbos
    Member
    Posted 2 years ago #

    thanks for the very quick response.
    The PHP version was 5.2... but am now using 5.3.13
    Also had WP-Table reloaded installed but deactivated; I have now completely removed it (including all tables etc)

    CSV file to tabe: I had NOT included http://; when I include it, the CSV file to table option works fine.

    I am however still having the same problem with commas in cell data, even after changing the [table] short tag or changing the Enclosure Parser Option

  4. takien
    Member
    Plugin Author

    Posted 2 years ago #

    Congratulations if you're use PHP 5.3.x now :) this could minimize the problem.

    Another plugin almost will not conflict with Easy Table unless they have same tag. I had anticipated this by providing the option the change the tag. so you can use them along with Easy Table safely.

    For the CSV URL, there may be a problem when URL contains special characters which should be urlencoded. I have not done this, but already in the todo list to prevent problems later on.

    About the enclosing data in a cell, you should not experience problems when using PHP 5.3.x, however if it happens, I need to know what exactly the data you enter so that I can check it. Feel free to send an email to me via the contact form on my blog.
    Thank you

  5. takien
    Member
    Plugin Author

    Posted 2 years ago #

    After trying setup with your table data I found that my plugin has a bug with comma if they're in the FIRST column in a row.
    Let me give me you a "temporary solution" until I fixed it. Place another cell in the first column, something this.

    [table]
    No,heading1,heading2
    1,"product1,product2,product3",description
    2,"product1,product2,product3",description
    3,"product1,product2,product3",description
    [/table]

    Or if you don't want to display item number, just start first column with a comma

    [table]
    ,"one,two,three",four,five
    ,"six,seven,eight",nine,ten
    [/table]

    Another solution
    Set delimiter with character other than comma and, eg. |

    [table delimiter="|"]
    heading1|heading2
    "product1,product2,product3"|description
    "product1,product2,product3"|description
    "product1,product2,product3"|description
    [/table]

    Thanks for helping me to find the bug,
    added to note to be fixed.

  6. takien
    Member
    Plugin Author

    Posted 2 years ago #

    fixed in version 0.7

  7. Cigeria
    Member
    Posted 2 years ago #

    Hello there, unfortunately, I have the very same problems here. Linking to a file doesn't work for me, I'm using php 5.3.6 and every single comma is recognized as a delimiter. I've tried everything you've mentioned here.

  8. takien
    Member
    Plugin Author

    Posted 2 years ago #

    @Cigera, have you checked the option Allow read CSV from file? in the plugin option page?
    If it still not work please provide detailed information such as :
    table data, screenshot, WordPress version, plugin version etc. Feel free to send it privately via contact form on my blog if you don't want to show it here.

  9. Cigeria
    Member
    Posted 2 years ago #

    Yes I have checked that option. I'm using WordPress 3.3.1 and recently installed the latest version of Easy Table 0.7.

    My table is composed somewhat like this:

    Code,Author,Title,Year,Coordinator
    A0001,Author1,"Title title title, title", 1955, Coordinator1
    A0002,Author2,"Title title title title", 1957, Coordinator2
    A0003,Author3,"Title, title title title", 1999, "Coordinator3, coordinator4"

    I actually managed to fix the comma problem, that one was my own fault. But the link to the *.csv file on the server still doesn't work for me.

  10. takien
    Member
    Plugin Author

    Posted 2 years ago #

    • make sure file URL contains no space, this bug already in my todo list.
    • and file url must accessible (try to access file directly from browser).
  11. Cigeria
    Member
    Posted 2 years ago #

    The URL doesn't contain spaces and it's definitely accessible.

    I'm thinking maybe the file is somehow wrongly written? You can download it here: link

  12. takien
    Member
    Plugin Author

    Posted 2 years ago #

    Then you need to check if setting of allow_url_fopen is ON in your PHP configuration. It should be ON to get plugin read from file to work. Ask your web hosting provider regarding to this.

    Next time I need to add plugin functionality to check first if allow_url_fopen is enabled and at least to notify user.

  13. Cigeria
    Member
    Posted 2 years ago #

    Thank you, that was exactly the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.