WordPress.org

Ready to get started?Download WordPress

Forums

Easy Instagram
[resolved] Not showing Instagram User ID (20 posts)

  1. Tina
    Member
    Posted 1 year ago #

    I followed your instructions exactly as they are posted here under "installation" and after I authorized Instagram to work with WordPress, instead of taking me to the Easy Instagram settings page on my site, it took me to the login page of my site. And when I go into Easy Instagram settings page, I see no Instagram User ID.

    http://wordpress.org/extend/plugins/easy-instagram/

  2. Tina
    Member
    Posted 1 year ago #

    Is it the same as the "Client ID"? That big long number at the top of the settings page?

  3. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Tina,

    And thank you for using our plugin.
    After registering with Instagram you have all the info in the "Manage Clients" panel : http://s.wordpress.org/extend/plugins/easy-instagram/screenshot-3.jpg?r=609103. You need to copy the Cliend ID, Client Secret and Redirect URL from here and paste them in the Easy Instagram Settings page in your WordPress administration area.

    Please let us know if you need further help.

  4. rcadden
    Member
    Posted 1 year ago #

    Further help is indeed needed. Once all the info in the 'Manage Clients' panel is entered, and the Client ID, Client Secret, and Redirect URL are pasted, I click 'Save Settings', and then click 'Instagram Login' below that. This takes me to the authorization page on Instagram.com, and I click on 'Authorize'. It then redirects to the WordPress login page, and when I login to my dashboard, it doesn't continue the redirect to the Easy Instagram settings page.

    Because this is broken, the settings page never updates with the User ID #, and the plugin widget won't work. I even used a separate service to find my Instagram User ID, but it still doesn't work.

  5. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hello-

    Thank you for sending a support request regarding this matter. We want you to have the best possible experience with our plugin, and have forwarded this issue to our technical team for review and follow-up.

    We will get back to you shortly.

  6. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    You get redirected to a wrong page after authorizing the application so it must be a problem with the Redirect URI value.
    Can you please make sure you have the same Redirect URI value in your Instagram application settings (Manage Clients) and in the plugin settings page ?
    The Redirect URI should be http://YOUR_SITE_URL/wp-admin/options-general.php?page=easy-instagram

    Thank you.

  7. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    @Tina,
    We have corrected a typo in the instructions, sorry about that. Glad you found something that worked for you.

    @rcadden,
    We have updated a new version as we were having some plugin compatibility issues, as well as the instructions typo. Hope you'll find version 1.2 meets your needs. Let us know.

    Thanks for your patience,
    VM

  8. jhuang238
    Member
    Posted 1 year ago #

    I have discovered the problem (after many hours). In the CurlHttpClient class, it is attempting to cURL a HTTPS site. cURL can be configured differently on different servers, sometimes entirely blocking HTTPS. I fixed it by inserting:

    "curl_setopt($this->handler, CURLOPT_SSL_VERIFYPEER, false);"

    into the "protected function _setOptions" function. Hope this helps.

  9. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    @jhuang238,
    We will include your fix in the next release.

    Thank you for your help,
    VM

  10. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    @jhuang238,
    We have included your fix in this release.

    Thank you again for your help,
    VM

  11. hkudrati
    Member
    Posted 1 year ago #

    Hello ,

    I have 1.2 version and i still have the same problem as rcadden .

    Please help

  12. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    @hkudrati,
    Can you please copy-paste here the values you used in the Instagram application admin for 'WEBSITE URL' and 'REDIRECT URI' and also the 'Application Redirect URI' value from the plugin's config page ?

    Thank you,
    VM

  13. hkudrati
    Member
    Posted 1 year ago #

  14. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Please follow these steps and let us know if it works for you:

    1. Open the plugin's admin page.
    2. In the same browser, open another tab, go to http://instagram.com/ and log in with your account. Do not close this tab.
    3. In the first browser tab, click on 'Instagram Login'. You should get your User ID without being redirected to the Instagram login page.

    Thanks,
    VM

  15. hkudrati
    Member
    Posted 1 year ago #

    My instagram is log'd in on the same browser with the wp admin page.

    But still no luck , tried again ..

    Thanks

  16. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hello hkudrati,

    We would be willing to try and see what the issue is, if would would please contact us through this page:
    http://www.velomedia.com/contact/
    and choose the Los Angeles office, one of our team will reply to you asap.

    Thank you.

  17. hkudrati
    Member
    Posted 1 year ago #

    that url is down ? i am getting read error with http://www.velomedia.com/contact/

  18. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hi hkudrati,

    Sorry for the inconvenience, we were doing some maintenance work but the site is back online. Can you please try again ?
    Thank you.

  19. VeloMedia
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Kudrati,

    We noticed that in your WP General Settings, the WordPress Address and the Site Address URLs are defined without the www prefix (http://sheeshagardencafe.com). However, in the Instagram settings your Redirect URI has the www prefix (http://www.sheeshagardencafe.com/...).
    Please make sure the Redirect URI in both the Instagram Application Config and Easy Instagram plugin have the same base URL, in your case without www, or change your site URL to include www.

    Thank you for helping us to find the source of this issue.

  20. hkudrati
    Member
    Posted 1 year ago #

    thank you , yes that fixed it :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic