WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] You can see through the fancy box screen (6 posts)

  1. tellfile
    Member
    Posted 2 years ago #

    I'm hooked on Easy Fancybox!

    Everything works fine except one day I happened to notice something funny when I re-clicked the link to open the layer in the same browser session.

    I could see the browser content behind the text that I was trying to read, which made it really difficult. Videos the same way.

    The only way to fix it was to reload the browser and click the layer link again. In other words each fancy box on my page only gets a one shot load to display properly (not be able to see through it).

    I have WordPress duplicated on my off line Wamp server with the exact same settings,theme plugins etc, and it doesn't suffer the re-click problem.

    Since it works right on the Wamp server, and not on my HostGator server, maybe it has something to do with server settings, which i wouldn't know the slightest about.

    If there is no easy solution, I can live with it. Most of my visitors probably won't click the links twice in the same session. I do notice about half of them making return site visits though.

    Charles

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Interesting case. It sounds like some CSS opacity rule lingers on after the first time. Do you have a link?

  3. tellfile
    Member
    Posted 2 years ago #

    Yes, I put it on a temporary post so you could find it without the clutter. At the below address, just open the box, then re-click to open again to see the difference.

    http://stellar-earnings.com/%20/2011/11/08/easy-fancy-box-demo/

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmm... I'm not seeing the problem you describe in Firefox, Chrome nor Opera so I'm guessing you are using Internet Explorer?

    I wonder if the fact that you have set the option Fade speed to 1500, half a second longer than the Closing speed option is causing this... As I cannot reproduce the effect (have not got IE at hand right now) I cannot test this theory. Could you give it a try, lowering the Fade speed to below the Closing speed?

  5. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Ah, no... I've found it (I think, please test)...

    Somehow, in some browsers, setting the option Transparency fade during elastic transition while Transition In is not set to Elastic (in your case: Fade) this fade effect gets only partially executed on the second try.

    As it does not produce any errors nor have this effect in all browsers, I don't know if this can be called a bug in the FancyBox script. I'll have to write a work-around for it in my plugin.

    In the mean time, could you either disable the transparency during transitions or switch to elastic opening transition manually?

  6. tellfile
    Member
    Posted 2 years ago #

    That did the trick!

    I set it to elastic instead of fade. I actually like it better that way!

    For your notes, I did make the changes you suggested earlier, but had no effect and I was using the Chrome browser as my default. I didn't think to test with other browsers.

    Upon testing, including with IE, I discovered Chrome was the only one doing it, at least my Chrome.

    I switched to another computer that runs on Windows XP, and the Chrome browser on it did the same thing.

    So the fade setting worked fine with Chrome on your server, and it works fine with Chrome on my Wamp server, but not so fine with Chrome on the HostGator server, which is used by both my computers. So it seems like maybe that has an element to it.

    But anyway, works fine now with the changed elastic setting!
    I can now take my little refresh note down for visitors!

    Thanks for all the help!

    Charles

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic