WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
Vimeo not working right (9 posts)

  1. SirMrDoctorTim
    Member
    Posted 1 year ago #

    Hello,

    First want to say awesome plug-in!

    I'm having an issue with putting in a fancybox vimeo on this page: http://algebranation.org/development/

    In the HTML widget I've entered:
    <a href="http://vimeo.com/34763287" class="fancybox-vimeo"><img width="450" src="http://algebranation.org/development/wp-content/uploads/2012/09/Screen-Shot-2012-09-21-at-11.55.02-AM.png"></a>

    And it automatically directs the image to the url after briefly showing a pop up.

    Any ideas on how I can fix this?

    Thanks in advance.

    Best,
    Tim

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tim,

    First, you need to enable the Vimeo option on Settings > Media and make sure auto-detect is on :)

  3. SirMrDoctorTim
    Member
    Posted 1 year ago #

    Thanks so much for the help.

    After ticking Settings > Media > Enable FancyBox for > Vimeo, I was able to get it to pop up perfectly.

    However, I've changed the image and video and I'm still having the same issue.

    HTML in the widget goes:
    <a href="https://vimeo.com/50063636" class="fancybox-vimeo"><img width="450" src="http://algebranation.org/development/wp-content/uploads/2012/09/Screen-Shot-2012-09-24-at-10.50.42-AM-copy.jpg"></a> I've also tried without class="fancybox-vimeo" along with emptying the cache.

    And here're a couple screen shots of what I've changed to make it show up: http://i.imgur.com/uvXbl.png & http://i.imgur.com/tWEdw.png

    Thanks again!

  4. SirMrDoctorTim
    Member
    Posted 1 year ago #

    So I figured it out: as long as i have http://vimeo.com, instead of https://vimeo.com, the pop up shows up!

  5. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Right, using https I see that effect too... I'll try to put a work-around in the upcoming version. Thanks for spotting it :)

  6. paris.sebastien@gmail.com
    Member
    Posted 1 year ago #

    Not workin...
    1- Settings > Media > Enable FancyBox for > Vimeo = checked
    2- Settings > Media and made sure auto-detect is on
    3- made sure to link to an HTTP://vimeo.com (and not HTTPS)
    4- used class="fancybox-vimeo" on my link
    5- made sure it'S not a cache issue (other browsers, other computers)
    Still, it opens the fancybox for a few seconds to then redirect to my Vimeo page full window
    Please advise
    Thanks

  7. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like FancyBox works correctly but Vimeo forces a redirect / break-out of the frame. Is embedding allowed for that video?

    Or does it only happen when you are logged in to Vimeo?

    If you have a link to your site, I can take a closer look.

  8. paris.sebastien@gmail.com
    Member
    Posted 1 year ago #

    THX.
    Nop it happens on other computers, other browsers, not logged into Vimeo, embeded allowed....
    Can't share the link. Secret project :(
    I can't be the only one out there....

  9. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Can you share the link to the Vimeo page so I can test with that? If you want, you can send it privately using the contact form on http://status301.net/contact-en/

    If not, th only tip I can give are:
    1. test with other vimeo movies;
    2. disable all other plugins and switch to the default Twenty Eleven theme for a minute to see if the issue remains;
    3. embed the video in an iframe straight in a page and see if that works...

    Hope you can figure it out :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags