WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] viewing vimeo fancybox on ipad (9 posts)

  1. fizzboompop
    Member
    Posted 3 years ago #

    trying to figure out the best approach to make a vimeo video appear in a fancybox on an ipad.

    at http://sunsawed.com/synch click the watch our video button on an ipad and it comes up with the fancybox, but the video never plays.

    the video plays fine on the ipad at vimeo.com

    thanks!

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    I have heard about problems with flash and pdf in FancyBox on an ipad before. Sadly, I do not own an iPad to actually see it happen. Nor can I tell you what goes wrong here. The iPad does not use flash to display movies on vimeo.com maybe? Is it HTML5 embedding being used there?

    You might get an answer on the FancyBox support forum http://groups.google.com/group/fancybox/

  3. fizzboompop
    Member
    Posted 3 years ago #

    Thanks for writing back Ravan.

    I now see that it works ok on the ipad in a normal post using the embed link which is an iframe. i'm not sure how to utilize it with easy fancybox ...

    current fancybox link:

    <img class="aligncenter size-full wp-image-103" title="play video" src="http://sunsawed.com/synch/wp-content/uploads/2011/02/getinsynch4.png" alt="" width="965" height="332" />

    vimeo embed iframe that works in a post (but which i'm not sure how to use with fancybox):

    <iframe src="http://player.vimeo.com/video/19221018?title=0&byline=0&portrait=0&color=ffffff&autoplay=1" width="800" height="450" frameborder="0"></iframe>

    Thanks again for your assistance! The plugin looks great!

  4. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    That's interesting... Try this:

    1. Enable iFrame support on the Settings > Media admin page

    2. Set dimensions 800 x 450 x 0 for it (or other width / height / border if you like)

    3. Use this code in your post (remove the spaces after each '<'):

    < a href="http://player.vimeo.com/video/19221018?title=0&byline=0&portrait=0&color=ffffff&autoplay=1" class="fancybox-iframe">< img class="aligncenter size-full wp-image-103" title="play video" src="http://sunsawed.com/synch/wp-content/uploads/2011/02/getinsynch4.png" alt="" width="965" height="332" />< /a>

    4. Let me know if that works :)

  5. fizzboompop
    Member
    Posted 3 years ago #

    Worked like a charm.

    Because the Vimeo iframe embed is HTML5 compatible, it is showing up perfectly on the iPad now.

    Thanks for the help Ravan. Will put some $ in the tip jar right away!

  6. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Any contribution will be much appreciated! :)

  7. jfthornton
    Member
    Posted 3 years ago #

    Hi Ravan

    I am in a similar situation. I got something working but my problem is that when the page loads the vimeo video launches. I would like the page to load and then the user clicks the lick to launch the fancybox.

    I copied this code you suggested above and still I have the same problem. Can you think what I can add to prevent this?

    test page;
    http://www.ponky.eu/722-2

    JOhn

  8. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Hi John, check the Easy FancyBox settings on Settings > Media. You have set the value for "Auto-trigger" to "First iFrame link"... Set it to "None" or "Manual" to disbable the behaviour.

  9. jfthornton
    Member
    Posted 3 years ago #

    Flipping brilliant! Ta.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic