WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
Undefined Index on Settings page (2 posts)

  1. carbis
    Member
    Posted 2 years ago #

    This is a bit of what my Settings page looks like:

    Notice: Undefined index: status in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 280

    Notice: Undefined index: status in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 280

    Notice: Undefined index: input in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 281
    Enable FancyBox for

    Notice: Undefined index: status in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 280

    Notice: Undefined index: title in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 311
    Images & Inline content

    Notice: Undefined index: status in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 280

    Notice: Undefined index: title in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 311
    PDF

    Notice: Undefined index: status in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 280

    Notice: Undefined index: title in /home/chch1521/public_html/wp-content/plugins/easy-fancybox/easy-fancybox.php on line 311
    SWF

    etc. etc.

    I've tried both on the current version of the plugin and the development version.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    You are seeing these notices in the browser on your settings page??? That's fine in a development environment but if you are on a live site, that should be addressed immediately. See more below.

    I thought I had defined all indexes in the dev version... If you are still using the dev version, can you tell me exactly which ones are there? Thanks :)

    Two steps to take on a live site:

    1. Switch off public display of errors. This is generally a good thing to do. There are several levels where you can do this, depending on your hosting and access to files and depending on rules being already in place (test them):
    A. In your PHP ini file set display_errors = Off
    B. In your .htaccess file set php_flag display_errors off
    C. In your wp-config.php set ini_set('display_errors', 'Off');

    2. Switch off reporting of Notices:
    A. In php.ini set error_reporting = E_ALL & ~E_NOTICE
    B. In .htaccess set php_value error_reporting 2039
    C. In wp-config.php use error_reporting(E_ALL ^ E_NOTICE);

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic