WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] [Plugin:Easy-FancyBox] with Nextgen not working (6 posts)

  1. lcvincent
    Member
    Posted 2 years ago #

    I had the site working with Easy-FancyBox and Nextgen galleries and now it's broken. There are several place where I have thumbnail from a gallery followed by a fancybox-hidden div and the actual gallery that I want to popup. The fancybox youtube links are still working so fancybox is working. And the thumbnail pops up - but not the gallery. The nextgen gallery will display ok when it's not hidden so I'm not at all sure what's wrong.

    I am working on the site with another person so I'm not sure if they may have done something that inadvertently broke it. I've gone through all the settings and even went as far as reinstalling the plugins. No luck.

    The link is http://ashamevlana.com/wordpress/mmedia/ and the live pics and studio pics should be displaying nextgen galleries.

    <div>
    <a class="fancybox" rel="" href='http://ashamevlana.com/wordpress/wp-content/gallery/live-pics/lg_ashatuning.jpg' title=''><img src='http://ashamevlana.com/wordpress/wp-content/gallery/live-pics/thumbs/thumbs_lg_ashatuning.jpg' alt='lg_ashatuning' class='ngg-singlepic ngg-none' /></a>
    
    <div class="fancybox-hidden">[nggallery id=1]</div>
    
    </div>

    As always, thank you for your help.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    It's the empty rel attribute in the first links. Make them match the rel attributes that are assigned to all the hidden links. So, in your case, for the first link use rel='set_1' and for the second set use rel='set_2'. You can remove the .ngg-galleryoverview from the auto-gallery FanycBox settings because that does nothing except replace the existing rel attributes set_1 and set_2 by gallery-1 and gallery-2 inside each div with class="ngg-galleryoverview" respectively.

  3. lcvincent
    Member
    Posted 2 years ago #

    Sorry, but I don't understand exactly what the rel="" is for. I had originally used the insert photo feature on the WordPress page, went to the nextgen gallery, selected the photo in thumbnail format, and inserted it. The link had the empty rel="". And I had it working. Now it doesn't work.

    I tried adding rel='set_1' and it didn't help.

    I removed the nextgen plugin and all related files and deleted the directories manually. I reinstalled nextgen and started rebuilding the galleries. No luck with or without the rel being set to something.

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    OK, I should be clearer but I gave two instructions:

    1. give that first thumbnail link the rel='set_1' attribute and the second one rel='set_2'

    2. remove the .ngg-galleryoverview from the auto-gallery Section(s) field in the FancyBox settings

    This last one is essential to make the first one work...

  5. lcvincent
    Member
    Posted 2 years ago #

    Got it. Thank you.

    You have a lot of patience with newbies. Thanks again.

  6. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Hey, no problem. You are welcome. Glad to see you got it working :)

    BTW, there is another method of using NextGen together with FancyBox to display only one thubnail image to open up a complete gallery. See instructions on http://wordpress.org/extend/plugins/easy-fancybox/faq/ where you see two methods (last one is with NextGen) under Can I use ONE thumbnail to open a complete gallery ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic