WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] nofancybox Class Not Working (6 posts)

  1. saxonycreative
    Member
    Posted 2 years ago #

    Hi there,
    I have Easy FancyBox enabled for iframes with auto-open turned off, and it's working great. The only problem is that whenever I add new pages to the WordPress custom menu, even with the nofancybox class, they are still opening in a Fancybox overlay. I can see that the nofancybox class is being applied to the li. For some reason, older pages that existed before the plugin was installed are not affected, even without the nofancybox class. Is this a bug, or is there some way around this?

    I look forward to your reply. Thanks!

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Are you adding these new pages as a sub of the original menu item that opens in FancyBox?

  3. saxonycreative
    Member
    Posted 2 years ago #

    Great question! Yes, I am... So I tested it. If I take a new link out from being a sub of a menu item that opens in FancyBox, the issue goes away. It only happens when the page is a sub of the original menu item that opens in FancyBox. Is there a way around this, or is the fix to make a parent that doesn't open in FancyBox?

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    You'll need the latest development version from http://wordpress.org/extend/plugins/easy-fancybox/developers/

    I added code to make the nofancybox class to work inside menu items too so if you add that as a class to the sub-menu items, FancyBox will refrain from attaching itself to those...

    Thanks for reporting the issue :)

  5. saxonycreative
    Member
    Posted 2 years ago #

    The dev version works perfectly for me... thanks for your help, and for working to resolve. All fixed!

  6. Tinpiliycfa
    Member
    Posted 1 year ago #

    Hello, I'd like to make fancybox disabled for On page. I actually use Galery on ONE page and it already open pictures like your plugin but with yours on it open pictures twice, yours over his.

    And even if I love your plugin, i'd like to disable it on that particular page so can you explain me how to do it please ? Thanks a lot how how to add class nofancybox ?

    I don't know what a class is or where to put it.

    a big thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic