WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Inline fancybox not working! (7 posts)

  1. RuggeroSB
    Member
    Posted 2 years ago #

    Hi There,

    I'm really stumped by this one. I've literally copied and pasted the example code for displaying inline content in a fancybox, and nothing happens when I click on the link.

    Adding a link to a .swf file just to see if the fancybox pops up works. Only the inline link doesn't want to trigger. Firebug shows no errors, only 1 instance of jquery is loading, and fancybox easing and css files are loaded in the code. I've also tried disabling all other running plugins to rule out any conflicts.

    The code I'm using is:

    <div class="fancybox-hidden" style="display: none;">
    <div id="fancyboxID-1" style="width: 460px; height: 380px;">...inline content here...</div>
    </div>
    <a class="fancybox" href="#fancyboxID-1">Read my inline content</a>

    You can see the page in question here:

    http://pietrociavattini.com/pagina-di-esempio
    User: test
    Pass: test

    Any ideas?

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, you need to re-enable FancyBox for "Images & Inline content" on your Settings > Media page.

  3. RuggeroSB
    Member
    Posted 2 years ago #

    I see. Pity, I'd have preferred more granular control as opposed to having to enable a globalised setting and now have to include the nofancybox class everywhere ellse all for just 2 inline popups.

    Nevertheless, thanks this did correct my problem.

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Instead of using the nofancybox class, you can disable the autodetect feature by clearing the auto-detect field from all extensions. There will be no more overhead for your 2 popups anymore and you can still use the class fancybox on both inline and image links to enable FancyBox for it.

    By the way, this goes for all media types except iframes. You can either use the auto-detect and exclude some with "nofancybox" or disable auto-detect and use the designated class (all starting with fancybox) to include particular links.

    Granular enough? ;)

  5. RuggeroSB
    Member
    Posted 2 years ago #

    Nice! Thanks RavanH that's definitely more "granular"! ;)

    The only extension which I could not find the auto-detect setting for was "PDF", unless I missed something?

    Thanks,
    Ruggero

  6. nadworks
    Member
    Posted 2 years ago #

    Sadly the changes I make in Settings > Media under "Title posting:..." have no effect on my existing thumbnails. They keep opening with that rather ugly floating black pill below the image. Bit frustrating because I'd hate to fiddle with the CSS.

    I have now tried all other option (inside, outside, overlay, flat), they are all the same.

    Any ideas?

  7. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Is there other FancyBox code inside your theme that overwrites the plugin settings? See trouble shooting on http://wordpress.org/extend/plugins/easy-fancybox/other_notes/

    If you provide a link, I can tell you more.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic