WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Fancybox not working/showing properly (7 posts)

  1. orkosl
    Member
    Posted 1 year ago #

    Hi,

    I'm new to WordPress and I don't really know how to set/use everything perfectly. I've just installed Easy Fancybox (also tried some other plugins), and this is the only one that seems to do anything at all.

    Fancybox seems to be working, but for some reason, I think the image box shows "too up" on the page (further than the actual web page, so not really showing the image).

    If I change the border settings to a really high value, for example, I get to see more of it, so that's why I'm guessing that the "only" problem is that the fancybox window is just loading on the wrong place.

    I'm using Architekt Theme, in case it's relevant.
    http://www.dessign.net/architekt-theme/

    I guess the way of resolving this issue is just a matter of changing something in the code. I'm really not an expert on this (code things look like Chinese to me, unfortunately).

    So, this is a link to the specific part on my site where I'm experimenting with the gallery. You'll be able to see what's actually happening in there.
    http://orkosl.com/arizia-sagardotegia/

    Thanks in advance.

    EDIT: When using firefox (I usually use safari), there is a different visualization error, which makes me think it's a problem when loading the images or something?

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    On http://wordpress.org/extend/plugins/easy-fancybox/other_notes/ there is a Trouble Shooting guide that would have helped you out. But to save you some time, I can tell you this from looking at the page source:

    There are many 'badly coded' (meaning, not adhering to WP guidelines and coding conventions) themes out there, and this is just one of them. The theme seems to have a hard coded call to it's own jQuery library thus breaking the already loaded one that comes with WordPress.

    A quick fix would involve the following steps:

    0. Make a backup of your theme files if you do not have one already.

    1. Open your themes header.php in the WordPress theme editor (read more on http://codex.wordpress.org/Editing_Files#Using_the_Theme_Editor_and_Plugin_Editor) and find the lines that are responsible for the following output. The lines will look slightly different because there will be some PHP involved (where the dots are) but you should be aable to recognize them.

    <script type="text/javascript" src=" ... /js/jquery-1.6.1.min.js"></script>
      <script type="text/javascript" src=" ... /js/jquery.nivo.slider.js"></script>  
    
      <script type="text/javascript">
      $(window).load(function() {
          $('#slider').nivoSlider({
          pauseTime: '5000',
          controlNav: false
          });
      });
      </script>
    </head>
    <body>

    2. Remove the complete first line

    <script type="text/javascript" src=" ... /js/jquery-1.6.1.min.js"></script>

    3. Change the line

    $(window).load(function() {

    into

    jQuery(document).ready(function($){

    4. Find the PHP call to the wp_head() function. It might look like this;

    <?php wp_head(); ?>

    Now put the following line of extra PHP code above it. But make sure it is inside the opening <?php and closing ?> PHP tags like so;

    <?php
    wp_enqueue_script( 'jquery' );
    wp_head();
    ?>

    5. Save the changes and revisit the front end.

  3. orkosl
    Member
    Posted 1 year ago #

    Thank you so much!

    It did work like a charm.

    Problem solved :)

  4. nilesha2010@gmail.com
    Member
    Posted 1 year ago #

    Hello My FancyBox for youtube video not working properly it open the window but not displaying that video. Please help me let I give you the link to the video..
    please click on the upper right corner video..
    http://www.bestwebsitesdesigner.com/testing.html

    where as same thing is working on other demo site..

    http://249development.us/johnsann/bwd/

  5. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi nilesha2010, the link is dead. Are you still having this issue?

  6. teddypork
    Member
    Posted 8 months ago #

    Hi!

    i took this out of the header:

    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.3/jquery.min.js" type="text/javascript" charset="utf-8"></script>

    now fancybox is working but the mousehover function at the homepage isnt :( can someone help me please? :)

  7. Ayaz
    Member
    Posted 8 months ago #

    split() is depreciated since php 5.3.0, kindly update plugin core files. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.