WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
Easy Fancybox not working (5 posts)

  1. Arkeen00
    Member
    Posted 2 years ago #

    Hello,

    I'm trying to use Easy-Fancybox to display jpg pictures from my nextgen galleries, but I can't make it work, even on non-NGG pictures. When I click on my picture link, nothing happens. I tried to disable some plugin using jquery, but I have still the same problem ...
    I have auto-detect on "jpg gif png", and apply to on "all images links".

    Here you can try : http://mickaelperrier.fr/traveljournal
    There is a single picture in the second post, then you can see the nextgen-galleries by clicking on the 'Voir les photos' button (yeah, it's in french) on next posts.

    I tried to check the trouble shooting issues, but I can't find why it's not working ...

    Sorry about my poor english, and thanks in advance for help.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    No idea why but for some reason the stylesheet is not being included. Without it, images open on the bottom of your page (scroll down after clicking an image) instead of overlaying the site content.

    You need to find out why the stylesheet is not being included. Can you switch off all other plugins for a minute to see what happens? If that does not change anything, it's the theme... Switch to Twenty Ten or Eleven for another minute to check if it works then.

    It won't solec the issue but least then you'll know where to search for the cause :)

  3. Arkeen00
    Member
    Posted 2 years ago #

    Ok, so I tried to disable all plugins one by one, but not a single change, but I switch my theme to twenty-ten, and ... it works.
    So I don't really know where it comes from, The only thing I know about Mystique (my theme) CSS is that it can be overwritten. Here is what I changed :

    span.hour
    {
        padding-left : 20px;
        font-family: Arial;
        font-size: 22px;
        font-weight:bold;
    }
    
    .shadow-left{background:no-repeat left bottom;}
    .shadow-right{background:no-repeat right bottom;padding-bottom:15px;position:relative;}
    
    #page
    {
      background-repeat:no-repeat;
      background-attachment: fixed;
    }
    
    #page-ext {
    background: transparent repeat-x center bottom;
    }
    
    #footer #copyright{
      padding:0.5em 0;
    }
    #site-title {
      padding: 0px 0 0px 0;
    }
    
    #cboxTitle {
      color: #000000;
    }
    
    .nav-main li.open > a, .nav-main li:hover > a {
      color: #BF1616;
    }

    Any idea ?
    (I let the twenty-ten theme for now, tell me if you want to see the other one again.)

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    There is nothing wrong with those style rules but what happens if you keep the default CSS in Mystique? I mean not overwriting it with or adding anything?

  5. Arkeen00
    Member
    Posted 2 years ago #

    Ok, I finally sort it out.
    There is an option in the Mystique's options > Advanced, called "Optimize website for faster loading", and the description says :
    Compresses and concatenates stylesheets and javascript files (using %s). Leave this unchecked if you're experiencing conflicts with other plugins, or if you're using a cache plugin that handles such functions
    I just uncheck this option and now everything seems to work fine.

    Thank you RavanH for your help ! Topic [Resolved] !

    (By the way, very nice plugin, it is exactly what I was looking for. It just would be perfect with some more options choices)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic