WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Easy Fancy Box and NextGen Gallery (10 posts)

  1. anvithks
    Member
    Posted 2 years ago #

    Hi,
    After searching through the heaps of queries I finally got how to add multiple NextGen Galleries to one page and use individual thumbnails.
    A new issue has cropped up though.
    The method I used was the following.

    [caption id="attachment_767" align="alignleft" width="150" caption="Infrastructure Gallery"]<a href="#gallery_infra" class="fancybox"><img src="http://new.orionehydraulics.com/wp-content/uploads/2011/07/6.-Conventional-Machine-Shop-150x150.jpg" alt="Orione Hydraulics Conventional Machine Shop" title="Orione Hydraulics Conventional Machine Shop" width="150" height="150" class="size-thumbnail wp-image-767" /></a>[/caption]
    
    <div class="fancybox-hidden">
    <div id="gallery_infra">
    [nggallery id=4]
    </div>
    </div>
    
    [caption id="attachment_792" align="alignleft" width="150" caption="Testing Facilities"]<a href="#gallery_testing" class="fancybox"><img src="http://new.orionehydraulics.com/wp-content/uploads/2012/06/Orione-Hydraulics-Customized-Cylinder-Testing-150x150.jpg" alt="Orione Hydraulics - Customized Cylinder Testing" title="Orione Hydraulics - Customized Cylinder Testing" width="150" height="150" class="size-thumbnail wp-image-792" /></a>[/caption]
    <div class="fancybox-hidden">
    <div id="gallery_testing">
    [nggallery id=5]
    </div>
    </div>

    I changed the setting of the Inline content and have segregated the galleries based on .ngg-galleryoverview.

    The problem is that on clicking the thubmbnail, a lightbox with the thumbnail of the gallery apppears. On clicking on this thumbnail again, the fullsize gallery appears.
    The link is http://new.orionehydraulics.com/gallery

    Click on either Infrastructure or Testing Gallery. Same thing happens inside Trade Fairs where there are 4 galleries.

    Please let me know if there is a fix for this.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Wow... this happens because with that first link to #gallery_infra you are actually going to show inline content: the complete gallery of thumbnails (each linking to their larger counterpart) is actually inside that box. It's just the first thumbnail that you see because of the limited size of the box. Clicking that thumbnail will subsequently load the full size image into fancybox.

    However ingeniously you have created this, you'll have to approach this completely differently if you want to avoid this effect.

    Follow the "With NextGEN Gallery" instructions under "Can I use ONE thumbnail to open a complete gallery ?" on http://wordpress.org/extend/plugins/easy-fancybox/faq/

  3. anvithks
    Member
    Posted 2 years ago #

    Thanks. I got what you are saying. I have done that before. When I use the method suggested in the FAQ's multiple nextgen galleries on the same page overrun into each other. I have tried the method sugested on another thread of setting the .ngg-galleryoverview class in the submit list. And changing the "All galleries in one" to "based on list."
    In this case at the end of the first gallery, the navigation does not cease. The next gallery opens in the Fancybox.

    Please let me know if there is a fix for the overrun issue.

    I will demonstrate if necessary.
    Regards
    Anvith

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmmm... that should not be happening. Could you reproduce the issue on your site so I can take a look?

  5. anvithks
    Member
    Posted 2 years ago #

    Hi,
    I have set the following :
    Media Settings : <img src="http://i.imgur.com/Tj3aa.png" title="Hosted by imgur.com" alt="" />
    The code on the gallery page is this :

    [caption id="attachment_767" align="alignleft" width="150" caption="Orione Hydraulics Infrastructure Gallery"]<a href="http://new.orionehydraulics.com/wp-content/uploads/2011/07/6.-Conventional-Machine-Shop.jpg" ><img src="http://new.orionehydraulics.com/wp-content/uploads/2011/07/6.-Conventional-Machine-Shop-150x150.jpg" alt="Orione Hydraulics Conventional Machine Shop" title="Orione Hydraulics Conventional Machine Shop" width="150" height="150" class="size-thumbnail wp-image-767" /></a>[/caption]
    
    <div class="fancybox-hidden">
    [nggallery id=4]
    </div>
    
    [caption id="attachment_792" align="alignleft" width="150" caption="Orione Hydraulics - Testing Facilities"]<a href="http://new.orionehydraulics.com/wp-content/uploads/2012/06/Orione-Hydraulics-Customized-Cylinder-Testing.jpg" ><img src="http://new.orionehydraulics.com/wp-content/uploads/2012/06/Orione-Hydraulics-Customized-Cylinder-Testing-150x150.jpg" alt="Orione Hydraulics - Customized Cylinder Testing" title="Orione Hydraulics - Customized Cylinder Testing" width="150" height="150" class="size-thumbnail wp-image-792" /></a>[/caption]
    <div class="fancybox-hidden">
    [nggallery id=5]
    </div>

    Link to gallery page : http://new.orionehydraulics.com/gallery

    Now the Gallery Does not open at all. Only the thumbnail image is shown in the fancybox.

    Please advise.

    Regards
    Anvith

  6. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    OK, first set up NextGEN as instructed at "Will a NextGen gallery be displayed in a FancyBox overlay ?" on http://wordpress.org/extend/plugins/easy-fancybox/faq/ (the rel="%GALLERY_NAME%" is important)

    Then switch off Auto-gallery in the FancyBox settings.

    Now use the method as described at "With NextGEN Gallery" under "Can I use ONE thumbnail to open a complete gallery ?" on http://wordpress.org/extend/plugins/easy-fancybox/faq/

  7. anvithks
    Member
    Posted 2 years ago #

    Thank you for your patience RavanH. I have performed the above steps. The code remains the same as in the previous post. I have changed all settings according to what you specified.
    The gallery doesn't load at all. Just the thumbnail.

    Earlier I had tried this with the Autogallery on and the galleries are not separated. The fancybox loads all images together.

    Please let me know if you have any suggestions.
    Thanks and Regards
    Anvith.

  8. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    You are not following the instructions. Don't try to make this work in what you created on your Gallery page but start fresh and follow the instructions closely.

  9. anvithks
    Member
    Posted 2 years ago #

    Thank you RavanH. That bit about starting over worked..:DI was so engrossed in getting it to work that I was not following steps properly. I was trying to link the thumbnail instead of just including the gallery.
    Its working now.

    Regards
    Anvith

  10. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Excellent :)

    If you ever find that using this method (with NextGEN) makes it impossible to get it to look like you want (alignment of thumbnails for example) you can always use the Manual method as described in the FAQ's. But you will not have the convenience of NextGEN gallery management...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.