WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Black Box with no Option to Close on First Click (5 posts)

  1. theworldofchinese
    Member
    Posted 2 years ago #

    When I click on a thumbnail for the first time, the close "X" is not clickable and it is not apparent how to close out of the first window that appears other than clicking, waiting, and clicking the close option that finally appears on the new window. There is a menu with numbers on the bottom that appears differently on the first window or frame than the subsequent images. Is this a bug, a problem with my NextGen settings, Fancybox settings, or is it meant to appear this way?

    Also, where do the settings for the Easy Fancybox plugin appear in WordPress?

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. theworldofchinese
    Member
    Posted 2 years ago #

    To further elaborate, when a thumb is first clicked a black box pops up it includes navigation numbers and arrows at the bottom and if I keep clicking these navigation arrows and numbers I can keep proceeding through the gallery. However, if I click twice on an image, the images suddenly have a white frame around them with arrows appearing now on the image towards the top and the close button is finally visible on the upper right hand corner.

    Is it supposed to have two layers of image frame styles and navigation formats like this? Or is there some setting in NextGen, Easy Fancybox, or something else that is causing different image frames and navigation to settings overlap each other?

  3. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    This is definitely not what is supposed to happen. There must be some conflict going on...

    Did you closely(!) follow the steps on http://wordpress.org/extend/plugins/easy-fancybox/faq/ to make FancyBox and NextGEN work together?

    If so, there is something else maybe inside your theme (like other lightbox scripts or jquery library being hard-code) or another plugin that conflicts. See troubleshooting steps on http://wordpress.org/extend/plugins/easy-fancybox/other_notes/

  4. theworldofchinese
    Member
    Posted 2 years ago #

    I figured out that the problem was the default NextGen JavaScript Thumbnail effect. In NextGen I went to Options, Effects, and next to JavaScript Thumbnail effect, I selected none. That did the trick.

  5. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, thanks for sharing! I'll add it to the instructions :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.