WordPress.org

Ready to get started?Download WordPress

Forums

Easy Digital Downloads
[resolved] Set Time Limit Warnings (14 posts)

  1. Eve Alexander
    Member
    Posted 2 years ago #

    Everything was working fine until I clicked a download link in my test email and got these errors:

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 81

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 84

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 85

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 86

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 87

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 88

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 89

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 90

    Warning: Cannot modify header information - headers already sent by (output started at /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php:81) in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php on line 91

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/scottyco/public_html/wp-content/plugins/easy-digital-downloads/includes/download-functions.php on line 494

    http://wordpress.org/extend/plugins/easy-digital-downloads/

  2. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    It looks like your server is configured with safe_mode on (this is a setting in your PHP config).

    Do you have access to your php.ini file?

  3. Eve Alexander
    Member
    Posted 2 years ago #

    I don't see it on the server. Hosting company does offer customer support on weekends. When we get to the php.ini file, what do I need to change?

  4. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    You need to set the safe_mode option 0 and off. Put this in your php.ini:

    safe_mode Off
    safe_mode "0"

  5. Eve Alexander
    Member
    Posted 2 years ago #

    Thanks Pippin! The hosting service set up the php.ini file and now the links work (partially). I finally figured out that you can't upload from the Media Library, only from your own computer.

  6. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    How do they only partially work? Is it just the upload part that doesn't work? If so, can you tell me what happens when you upload from the media library?

  7. Eve Alexander
    Member
    Posted 2 years ago #

    When I uploaded from the Media Library, Adobe Acrobat didn't recognize the files and would not open them. I realized they lacked the .pdf at the end which the Media Library was removing. So I removed all files from the Media Library and reuploaded from my computer instead. Now it all works like a charm. Hope my client makes a lot of money selling his ebooks thanks to you!!!

  8. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    I suspect that if you click "File URL" before clicking "Use this File" when uploading from the Media Library, everything will work fine.

    Glad to help!

  9. Mizi91
    Member
    Posted 1 year ago #

    Hello,

    I have the same problem here:
    http://www.timemanagementhero.com/downloads/31-hour-day/

    I have tried both solutions mentioned here, but it did'nt help.
    Do you have any other ideas?

  10. Do you have access to your php.ini file?

  11. Mizi91
    Member
    Posted 1 year ago #

    No, I don't, but safe_mode is set off.

    http://timemanagementhero.com/info.php

  12. Who are you hosted with?

  13. We've just fixed this problem for the next release: https://github.com/pippinsplugins/Easy-Digital-Downloads/pull/555

  14. Mizi91
    Member
    Posted 1 year ago #

    Its hosted with http://www.wedos.cz/
    ...
    Oh, great! :-) when are you going to release next version?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.