WordPress.org

Ready to get started?Download WordPress

Forums

Easy Digital Downloads
[resolved] Not Working - Checkout (cart) Is Always Empty? (46 posts)

  1. Do you have a caching plugin enabled?

    I use hostgator with zero problems.

  2. nonstop99
    Member
    Posted 1 year ago #

    Damn. That worked. Sorry I feel like a dumbass. Thats all it was.

    I disabled WP Super Cache Settings.

    So does this mean I can't use any cache plugin?

    - Steven

  3. No problem. You can use Super Cache but you have to configure the settings correctly. We have a doc on it: https://easydigitaldownloads.com/docs/wp-super-cache/

  4. nonstop99
    Member
    Posted 1 year ago #

    Your the man Pippin.

  5. Glad to help.

  6. This problem has now been completely resolved in 1.3.4: https://github.com/pippinsplugins/Easy-Digital-Downloads/issues/394

  7. chickc
    Member
    Posted 1 year ago #

    Im running Version 1.4.0.3 and have checked everything listed in these posts and am still getting a Cart Empty when going to Checkout. Any clues? Thanks.

    Heres my system info:

    ## Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL: http://iwholistic.com/access
    HOME_URL: http://iwholistic.com/access

    EDD Version: 1.4.0.3
    WordPress Version: 3.5

    Platform: Apple
    Browser Name: Safari
    Browser Version: 5.1.7
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_6_8) AppleWebKit/534.5
    7.2 (KHTML, like Gecko) Version/
    5.1.7 Safari/534.57.2

    PHP Version: 5.3.13
    MySQL Version: 5.0.91-log
    Web Server Info: Apache/2

    PHP Memory Limit: 256M
    PHP Post Max Size: 20M

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: page
    Page On Front: Store #30
    Page For Posts: Store #30

    Session: Enabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/php_sessions
    Use Cookies: On
    Use Only Cookies: On

    UPLOAD_MAX_FILESIZE: 20MB
    POST_MAX_SIZE: 20MB
    WordPress Memory Limit: 40MB
    WP_DEBUG: Off
    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Ajax Event Calendar: 1.0.4Contact Manager: 5.4.2Easy Digital Downloads: 1.4.0.3Easy Digital Downloads Toolbar: 1.4.4No Comments On Pages: 1.0.2
    CURRENT THEME:

    Cresendo: 1.0

    ### End System Info ###

  8. @chickc can you provide a live URL so that I can see it happen live?

  9. chickc
    Member
    Posted 1 year ago #

  10. Thanks.

    Who is your host?

  11. chickc
    Member
    Posted 1 year ago #

    Me. i have a dedicated server

  12. chickc
    Member
    Posted 1 year ago #

    anything?

  13. Great, thanks.

    Do you have server side caching enabled? It appears that items are added to the cart just fine, but then the cache isn't updated so the items aren't detected on page reload.

  14. chickc
    Member
    Posted 1 year ago #

    Where might I look to adjust that?

  15. Well it depends on what caching system (if any) it is.

    Did you setup your dedicated box or is through a hosting company that sets it up for you and then hands over control?

  16. chickc
    Member
    Posted 1 year ago #

    No, I have a dedicated server at a cyber center and have a outsourced server admin. I will ask him about this. Thanks. More soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic