WordPress.org

Ready to get started?Download WordPress

Forums

Easy Digital Downloads
[resolved] Email Problems? (10 posts)

  1. revivalgraphics
    Member
    Posted 1 year ago #

    I'm trying to configure EDD, and I'm having a problem with the email confirmation/checkout. After I click "Purchase" from my cart, this message is displayed:

    Warning: Invalid argument supplied for foreach() in /home/revival/public_html/wp/wp-content/plugins/easy-digital-downloads/includes/email-template.php on line 35

    Warning: Invalid argument supplied for foreach() in /home/revival/public_html/wp/wp-content/plugins/easy-digital-downloads/includes/email-functions.php on line 51

    Warning: Cannot modify header information - headers already sent by (output started at /home/revival/public_html/wp/wp-content/plugins/easy-digital-downloads/includes/email-template.php:35) in /home/revival/public_html/wp/wp-includes/pluggable.php on line 881

    This happens both in and out of test mode, and I unfortunately don't know enough to look at the code and fix it myself. What is going on/am I doing something wrong?

    http://wordpress.org/extend/plugins/easy-digital-downloads/

  2. revivalgraphics
    Member
    Posted 1 year ago #

    I would also like to add that this only happens when I have a price set on an item. Items with no price, everything works fine.

  3. Which payment gateway are you using? Test or PayPal?

  4. revivalgraphics
    Member
    Posted 1 year ago #

    As of right now, PayPal.

  5. revivalgraphics
    Member
    Posted 1 year ago #

    I think I've figured the problem - while in test mode under General, I should also be in test mode under Payment Gateway. I just tried it out with a priced item and everything worked great.
    Thanks for your fast reply and help!

  6. Are you using the PayPal version included with the plugin, or the paid add-on? There should only be one Test Mode option . . .

  7. revivalgraphics
    Member
    Posted 1 year ago #

    Nope, I didn't install any add-ons. Sorry for being confusing.
    What I meant is that in Settings, under the General tab, I've selected "Test Mode", and also under the Payment tab, I've selected "Test Gateway".

    Unless that's not the right way to be doing things :S

  8. Aha! Yes, that is correct :)

  9. revivalgraphics
    Member
    Posted 1 year ago #

    Awesome! Again, thanks for your help. I really appreciate the quick reply when I don't know what I'm doing.

  10. No problem! If you run into any more road blocks, just ask away!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags