WordPress.org

Ready to get started?Download WordPress

Forums

Easy Digital Downloads
[resolved] Email From Field (13 posts)

  1. kingtas
    Member
    Posted 1 year ago #

    Hi, I'm testing this awesome plugin and have a couple of questions.

    The Email is sent to buyer and seller but both emails have the from field as:

    myhostingaccountname@ibiza.medialayer.net on behalf of; WordPress [wordpress@mydomain.com]

    Obviously, this is bad. Can you tell me how to fix this?

    Also, I am using Putlook 2007 and the link in the email is not clickable.

    Thanks.

    http://wordpress.org/extend/plugins/easy-digital-downloads/

  2. kingtas
    Member
    Posted 1 year ago #

    I tested with a yahoo email address and the from field looks better and I can click on the link but I get a server message - You do not have permission to view this file.

    Any help on this issue?

  3. For updating the From name, I'd suggest that you install the Configure SMTP plugin. It will give you better control over how the emails are sent.

    There is a known conflict with Outlook 2007 right now. One thing to make sure of is that your download files have both a name and a URL specified, and not only a URL.

    The permission error is most likely happening because the payments haven't been marked as complete. You can check this by going to Downloads > Payment History and looking to see if the payments show "pending" or "complete". If they show as pending, please consult the FAQs.

  4. kingtas
    Member
    Posted 1 year ago #

    Thanks for the response.

    Roger on the Outlook 2007 and the SMTP plugin.

    I have both a name and a URL specified.

    I am testing with a free product marked 0 dollars and payment history is marked complete. I still get "You do not have permission to view this file" when the email link is clicked. I have disabled WordPress Firewall 2 and the result is the same.

  5. Can you give me the URL shown in your browser when you get that error?

  6. kingtas
    Member
    Posted 1 year ago #

    Sure.

    http://www.wpnirvana.com/downloads/cho-theme/attachment/cho-2

    The file shows as cho-2 because I deleted the download and started all over again. Same results.

  7. Ah I see the problem.

    When you insert the file URL in the Download Configuration, click the "File URL" before clicking "Use this File". You have used the attachment URL instead of the direct file URL.

  8. kingtas
    Member
    Posted 1 year ago #

    Awesome pippin. It's now working. Thank you for your help.

    One more question. Any way to clear my logs since they're now cluttered with bogus sales/downloads?

  9. You can delete the purchases from the Purchase History page. This will also reset the sales/earnings stats. It will not, however, remove the items from the Purchase/Download Logs.

    Avoiding bogus purchases is what Test Mode is for :)

  10. kingtas
    Member
    Posted 1 year ago #

    Test mode? We don't need no stinkin test mode! LOL

    Thanks for the help, Pippin!

  11. Haha, glad to help.

  12. Michael Cannon
    Member
    Posted 1 year ago #

    @Pippin - where in the documentation was the following?

    When you insert the file URL in the Download Configuration, click the "File URL" before clicking "Use this File". You have used the attachment URL instead of the direct file URL.

    I made the same missing, upload a file, click insert.

    I'm wondering if a better means to educate the user is needed or I just need to RTM closer.

  13. @Michael Cannon - It's actually not in the documentation, though I should add it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.