WordPress.org

Ready to get started?Download WordPress

Forums

Easy Automatic Newsletter Lite
[Plugin: Easy Automatic Newsletter] Cron error (4 posts)

  1. mawosola
    Member
    Posted 1 year ago #

    I would like to use this plugin. I have tested it and it looks good. Unfortunately, I keep getting a error message when the cron runs:

    "PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0"

    Can anyone help me solve this. I hate to give up on this plugin.

    Thanks

    http://wordpress.org/extend/plugins/easy-automatic-newsletter/

  2. PillarDev
    Member
    Plugin Author

    Posted 1 year ago #

    Hi mawosola,

    Thanks for taking interest in the plugin.

    Please provide us with your hosting environment (I.E: Are you using GoDaddy, BlueHost, MediaTemple, etc)

    "PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0"

    Based on the error output you provided looks like your server environment has PHP safe mode enabled in configuration and you are using PHP 5.3x. Safe mode is depreciated in the version your using. The latest version of PHP has safe mode obsolete. Depreciated means you can use safe mode but suggested to not use it since it will be obsolete (cannot use) soon.

    Your solution would be to turn safe mode off in your PHP configuration. Assuming you have full root control over your server you'd edit /etc/php.ini to put safe_mode to off. Depending on your hosting environment turning safe mode off will be different.

    "PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imap.ini on line 1 in Unknown on line 0"

    In both cases these messages are warnings and should not stop the Cron from running. It would seem your environment was updated but the configurations need to be fixed as well.

    Regards,
    George

  3. osmsolutions
    Member
    Posted 1 year ago #

    In CPanel, I get an AJAX error when I set up my cron.

    Repro:
    1. Go to CPanel/Cron Jobs
    2. New Cron Job
    3. Enter settings below
    4. Click Save, get AJAX Error

    I tried a bunch of things, and all 3 variations (php, wget, curl) and get AJAX error with each. I tried removing the space before the /dev/null 2>&1, I do not get AJAX error. However; the Newsletter status shows nothing after "Next Newsletter Scheduled : " so I think it's not going to send anything out on Sunday when next scheduled.

    Host: Hostgator
    Linux reseller hosting
    Apache version 2.2.22
    PHP version 5.2.17

    Any ideas?
    ___________________________

    Settings:
    Minute : 0
    Hour : 6
    Day : *
    Month : *
    Weekday : 1
    Command : php -q /home/brentwoo/public_html/wp-content/plugins/easy-automatic-newsletter/ean-schedule-newsletter.php > /dev/null 2>&1

  4. PillarDev
    Member
    Plugin Author

    Posted 1 year ago #

    That PHP version is old and may be causing some of the issues you are receiving. Please upgrade to the latest PHP 5.3x or PHP 5.4x. You can either do that yourself or contact the host and request it to be upgraded.

    What version of EAN are you using? Recently EAN 2.7.1 was released have you upgraded to the latest? You may also want to try installing the plugin manually by:

    1. downloading the plugin from http://wordpress.org/extend/plugins/easy-automatic-newsletter/
    2. Uploading it to your WP plugins directory
    3. Activating in admin panel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.