WordPress.org

Ready to get started?Download WordPress

Forums

Easy Ads
[resolved] Broken (8 posts)

  1. webeida
    Member
    Posted 2 years ago #

    I tried installing Easy-ads-lite 2.0 but it would not activate due to some fatal error.

    http://wordpress.org/extend/plugins/easy-ads-lite/

  2. manojtd
    Member
    Plugin Author

    Posted 2 years ago #

    May I know what the error is? And also your PHP version, if you have it. Thanks.

  3. webeida
    Member
    Posted 2 years ago #

    I've no idea what version PHP I have but the error I'm getting is as follows:

    Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /content/Hosting/b/a/babogue.com/web/wp-content/plugins/easy-ads-lite/easy-ads.php on line 44

  4. manojtd
    Member
    Plugin Author

    Posted 2 years ago #

    This plugin requires PHP5.3+. It actually checks for that version and is supposed to exit gracefully if the version is too old. Looks like the check doesn't work for some versions of PHP! I will check it out and and push a fix.

    Thanks for reporting it. Appreciate it.

    If you are willing to run a test for me, could you edit the file validate.php in easy-ad-lite and change line 20 to:
    $phpVersion = floatval(phpversion()) ;

    And let me know if the activation gives a sensible message? Thanks.

  5. webeida
    Member
    Posted 2 years ago #

    I managed to check my PHP. I've 5.2 installed so hence why it won't work.

    I also updated line 10 in validate.php but I still got the same error when I tried to activate it. So, it's not exiting gracefully :-)

  6. webeida
    Member
    Posted 2 years ago #

    when I said line 10, I meant line 20.

  7. manojtd
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for testing. I will find some other way of enforcing the version requirement.

  8. manojtd
    Member
    Plugin Author

    Posted 2 years ago #

    I think this issue is now fixed. Please give it a go if you get a chance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic