WordPress.org

Ready to get started?Download WordPress

Forums

DynPicWaterMark
Dont work (16 posts)

  1. Kvanto
    Member
    Posted 3 years ago #

    Dont work insert my watermark

  2. Tomasrg
    Member
    Posted 3 years ago #

    Yes, donĀ“t work. Nobody reply ? Thanks

  3. jasonwlangley
    Member
    Posted 3 years ago #

    Just want to add my not working vote- Wish somebody could get this to work, it would be great. Can't seem to find any contact info for the plugin owner...

    -Jason

  4. dduenke
    Member
    Posted 3 years ago #

    I was able to install it tonight on WordPress 3.1.3. I had to change the Memory Limit in the DynPicWaterMark settings to "64" instead of "General PHP.ini value". Hope this helps!

  5. SteelD
    Member
    Posted 3 years ago #

    I would like to use this but also can't get it to work. I think it is a great idea and there doesn't seem to be anything else like it. So, I've been going through the plug-in code and I have found two issues so far:

    1. If you have an absolute upload path set in WP and this isn't identical to what's embedded in the page as the image URL, this will cause problems (it did for me). Solution for me was to remove the WP upload path and use the WP default which then resulted in the right paths being used for the images.
    2. Some calculations appear to be missing from the code. After adding some extra code, I have managed to get this to work in WP 3.2.1. However, some other calculations may be suspect as they are based on the uploaded image size and not on the displayed image size. I need to do some more work on this.

    Essentially, my feel is that there isn't any fundamental reason why, with a little work, we can't get this to work in WP 3.2.1. It's a clever bit of coding by the original author but as it stands it doesn't work for all combinations of settable options. If you do get it to work, then you are lucky in that the code handles the combination of options you have chosen.

    I shall continue to work on this and see if I can post a workable version at some stage. I've never developed a WP plugin before (and neither am I a PHP expert) so I am having to learn as I go along but it's been an interesting few hours so far!

    BTW, I have an e-mail address for the plugin owner and have sent him an e-mail. Maybe he can help too.

  6. ayman07
    Member
    Posted 2 years ago #

    @SteelD could you post up a fix for this thing. I know your not the developer but it seems like you are 1 of 2 people who has managed to get this thing working. Its a shame that the developer has abandoned this project. I appreciate any help you can offer.

  7. SteelD
    Member
    Posted 2 years ago #

    Yes, I got it working for my site by tweaking bits and pieces. I planned to fix it up to make it more generic for any site but I've been too busy. I could take a look at doing this at the weekend. Could somebody advise me of the best way of posting a patched version of this?

    If anybody wants to see it working, go to http://www.minds-eye.org.uk and click on an image.

  8. ayman07
    Member
    Posted 2 years ago #

    That looks spectacular! Question, did you have to regenerate the thumbnails for this to work or should it just work after enabling it? I mean, I know you had to do some tweaking but theoretically speaking, should this have been a plug and play or did you had to do something to the images to get this to work as well? Thanks!

  9. SteelD
    Member
    Posted 2 years ago #

    It should just work. That's the whole purpose of this plug-in - the watermarks are generated dynamically so your original pics remain unmodified. This means you can readily update the watermark whenever you want. That's why I was determined to fix it myself if nobody else could.

  10. ayman07
    Member
    Posted 2 years ago #

    The reason I asked was because there was another plugin that put on watermarks and it wouldn't work unless I regenerate the thumbnails.

    I would really appreciate if you could help us out. I know you are busy but I sincerely appreciate what you can do. I might just put a job up on elance.com and see if someone could fix this for $20 or something. I would much rather donate it to you since you already fixed it. There is this site that is copying my work and I am afraid my images will be next so thats why I want the fastest way to get watermarks up. Please keep us posted.

  11. SteelD
    Member
    Posted 2 years ago #

    OK, as promised, I might have something for you. My own version of the plugin is too customised for my site so I went back to the original plugin to see if I could fix that. Rafael should be commended for doing an excellent job but there were a few areas that needed tidying up to make it more robust and more generic. I've spent a few hours this weekend working on it.

    Now, I'm no WordPress or php expert but I've created a version 1.2 of the plugin which you may download from http://www.minds-eye.org.uk/downloads/dynpicwatermark.1.2.zip. Let me know a) when you have downloaded it (so I can remove the link until we have given it a good test), and b) how you get on when you try it. I have tested it under a fresh install of WordPress 3.2.1 and it looks good to me (apart from one minor incompatibility with IE - see the readme.txt file). I have also made one or two enhancements to it.

    As soon as we have something that works, I will finalise it, write up some better documentation for it, and upload it to the WordPress plugins area for others to use.

    Good luck!

    David

  12. ayman07
    Member
    Posted 2 years ago #

    Thank you for doing this.

    1) I have downloaded it.

    2) I have installed it as I would with any plugin but it still doesn't work. I activated the plugin, chose which image to use as my watermark, and selected it to be in the bottom right of my image. i put forced default as yes, watermark all images yes, debug on. memory limit I tried 64 and 128, nothing. all the images are uploaded to wp-content/uploads as normal. they are in their individual folders categorized by the date. Any thoughts?

  13. SteelD
    Member
    Posted 2 years ago #

    OK, do you have a trace.log file in the plugins folder? Take a look at that. There may be some clues there. Have you tried this with the default template? Do you have other plugins installed? Do you get the plugin options when uploading a new image (that verifies that the plugin is being called)? Do you use the default WP plugins folder structure? What version of WP are you running?

  14. SteelD
    Member
    Posted 2 years ago #

    There are other options we can explore as well. I can give you access to my test enviroment so you can compare your setup with a working version. Can you e-mail me at david@minds-eye.org.uk and we'll continue the conversation there.

    I might also add more debug info to the trace.log in case some of the php functions don't return the desired result. I am determined to crack this since it is the only plugin of its type that offers great flexibility without altering images and as such should be of interest to a great manay photographers and artists who wish to protect their work from image piracy.

  15. kmeronuk
    Member
    Posted 2 years ago #

    Hi David,

    Any recent news on the status of your tweaks to this plugin? I'm in need of this sort of plugin so I'd be interested in testing it out and reporting back to you and otherwise helping where I can.

  16. Adam Robertson
    Member
    Posted 2 years ago #

    Thanks David for leaving the link to your modified version of this plugin up. I have downloaded and am testing it now. So far so good.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic