WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
[resolved] WidgetID is not valid (11 posts)

  1. protera
    Member
    Posted 2 years ago #

    Hello.
    Thanks for great plugin, but i have a problem when i save a new widget (Quick adsense).

    I get an error : "WidgetID is not valid" and nothing is saved :-(
    WP 3.3.1

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmm... is that the only widget with this problem you have?

  3. yours2share
    Member
    Posted 2 years ago #

    Hello,
    I'm having the same problem with the WP Paypal Shopping Cart widget.

    I've also tried using the simple Text widget, and set it to display one of the three languages only (using WPML plugin for languages). This saved and appears to be displaying on the right pages. As I saved, I did get an error
    Warning: Illegal offset type in isset or empty in /home/xxxxxx/public_html/wp-includes/taxonomy.php on line 211

    I then rest the widget to static, then set up with the posts set to No, the same error occurred, but changes appear to have been saved.

  4. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    I think I have found why the "Invalid WidgetID" error occurs. It's because WP has changed a few versions ago the way widgets are handled in the system. The widgets to which this errors occurs have been registered to WP using a deprecated method. In other words: The widget is made available in an old fashioned way. WP can stil handle it (for the time being), but unfortunately DW can't.

    I'm not able to fix this in DW or create a workaround for it. The change has to be made by the author of the widget. I'm actually 'guilty' myself with my other plugin which also creates widgets uing the old fashioned way. Going to fix that....

    The taxonomy warning is not critical. Everythng is saved and works. However, it's ugly and not meetng my high stndards. The warning has been fixed in the latest development version.

  5. yours2share
    Member
    Posted 2 years ago #

    Thanks for the quick reply. I'll ask WP Paypal Shopping Cart if they are going to sort this out.

  6. mished
    Member
    Posted 2 years ago #

    I encountered this same "widgetID is not valid error when using Dynamic Widgets on the FV Community News plugin (http://wordpress.org/extend/plugins/fv-community-news/).

    Per your suggestion, I raised the issue re: registering the widget using a deprecated method and his response is here: http://www.frank-verhoeven.com/forums/topic/fv-community-news-alpha-2/#post-707.

    I wonder if yours2share has received word from the WP PayPal Shopping Cart developers yet if they do, in fact, use a deprecated method for registering widgets.

  7. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    After some extra investigation I found out when you don't hit 'Save' after adding a new widget to the sidebar and go straight to the DW options, you might run into this error. So, make sure you've hit 'Save' before going to the DW options.

  8. mished
    Member
    Posted 2 years ago #

    Now that's interesting ....

    So I just tried it on the FV Community News plugin .... and it worked!

    Thanks!

  9. Michael
    Member
    Posted 1 year ago #

    Was this problem eventually solved? I'm using Ultra Shopping Cart and also have the "WidgetID is not valid" error. Tried the suggestions here and still no joy. All other widgets show the normal display options except Ultra. When I try to change from Static setting or Primary to block or text or modify the widget settings in any way it won't save the change either. Appreciate any help.

  10. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    For the widgets which are using the deprecated method of registering to WordPress, this needs to be fixed by the author of the widget.

  11. Michael
    Member
    Posted 1 year ago #

    Thank you for quick response. Will take it up with Ultra.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic