WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
When adding new Dynamic widgets, they disappear after refreshing (9 posts)

  1. sledge81
    Member
    Posted 2 years ago #

    I've been using dynamic widgets across my sites. Built a fair # of dynamic widgets. The latest widget i added (set all to no, with expection to single post) appears fine in the post that is set, but later disappears.

    Tried to upload the dump file but its 223KB and your form doesn't allow files of that size. Any help?

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. sledge81
    Member
    Posted 2 years ago #

    UPDATE:

    Did the usual (disable plugins stuff). There seems to be conflict with two plugins. (The Slide) and Nrelate slide.

    Fixed this issue by first disabling the plugins, then adding the widgets to the post and the re-enabling them. This way it works.. although I think there is a more logical explanation to this issue.

  3. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Are the widgets removed from the sidebar or just disappear where the widget should appear?

  4. sledge81
    Member
    Posted 2 years ago #

    The widgets are removed after either:

    a) refreshing the same page
    b) visit another page and going back to the same page

    I could replicate this for you if the bug is something that cannot be explained via the forum (would be nice if you could be online as well at the same time, as it would involve showing on a live site).

  5. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Do you press Save at the widget after dropping it in the sidebar?

  6. sledge81
    Member
    Posted 2 years ago #

    Yep. But as stated earlier, the widgets disappear.

    Also the same issue comes up if editing a previously published post as well. Upon publishing the post after editing, the widgets disappear.

  7. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm... The only thing I can think of is a clash bteween nrelate and DW. DW uses the top parent postID as a reference. Maybe nrelate changes this top parent postID causing DW not able to find the ID anymore. But that doesn't explain why the widget is removed at the admin side of the sidebar. DW does not control the admin side of the sidebar. Do one of the other plugins?

  8. sledge81
    Member
    Posted 2 years ago #

    Hi Qurl,

    I meant to say the widgets disappear on the front end, precisely, the posts where they were checked to be displayed. Hope this helps.

  9. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Ah ok, DW might get confused there. Try to use the OLD method.
    At the DW overview page, go to the bottom and click 'Advanced'. Thick 'Use OLD method'.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic