WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
Unable to Disable Widgets with Events Plugin (6 posts)

  1. Tony Bianco
    Member
    Posted 2 years ago #

    I'm using the Dynamic Widgets with "The Events Plugin" and for some reason I am unable to disable particular widgets on the events page. I've tried every single option and to no luck am I able to disable widgets. Has anyone else ran into this problem similar to this?

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Without looking to the Events plugin (yet), I guess the events plugin creates a special page which probably is not recognized by DW. When DW does not recognize a page, it falls back into failsave by not following any rules. It would probably need an extension to recognize it.

  3. Tony Bianco
    Member
    Posted 2 years ago #

    That's the weird thing that's happening is that it's not using the failsafe where it posts up the basic stuff, but another set of widget rules.

    It does recognize "The Events" plugin as custom post times. However it still does not exclude the widget I need excluded from that custom post type page.

  4. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    I guess you're talking about the main events page. Did you use the Custom Post Type Archives settings in DW for that?

  5. Tony Bianco
    Member
    Posted 2 years ago #

    Yes I did. In fact that was the first thing I tried. It does recognize the Event plugin as it's own menu system. I can disable widgets for that plugin but only on the individual event page but not on the calendar page.

    I'm playing around with every possible configuration and nothing working on the main calendar page.

    And it's an all or non sort of a deal. On the Events menu within dynamic widget if I click on "Show Widget on Events" as yes, then click the individual event that says "Except for: [EVENT NAME]" it doesn't work. I have to click on "No" to exclude the widget. All or none.

    I will see about creating a screencast to show you what I mean.

  6. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe putting DW to use the OLD method is the solution in this.
    At the DW overview page, click Advanced at the bottom. Tick the checkbox next to "Use OLD method".

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic