WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
[resolved] Display on individual posts (7 posts)

  1. emma.echter
    Member
    Posted 1 year ago #

    Hi,

    Just wondering if there are any know work arounds for the widget not working on individual posts. I have it running on my local development server, and this is working.

    When I moved to the production server, this is no longer working.

    I sent this via your site too, but thought I'd ask here too.

    Would you like me to provide dumps of both - would that help to find why the error is happening?

    I'm under alot of pressure to launch the site which was 'ready' - so would like to find a resolution...

    Hope to hear from you soon.

    Emma.

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    You can try OLD method. At the DW overview page, at the bottom, click Advanced. Then tick the checkbox for OLD method.

  3. emma.echter
    Member
    Posted 1 year ago #

    Hi, thanks for getting back to me.

    Have tried OLD method - set to old, then reset all and re-configured. when this didn't work, then deleted and re-made the instance of the widget. Both did not work... Any other ideas?

    Thanks again, Emma.

  4. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm... actually not really ideas. There must be some difference between your local test environment and the production environment. Did you do a one-on-one copy keeping everything the same like database name, prefix, etc.?

  5. emma.echter
    Member
    Posted 1 year ago #

    Hi, yes, I copied the files to the live server exactly - did a DB export and loaded it in...

    I was having a look at the live servers settings - the only thing I can think it might be is the PHP or MySQL versions.

    Local: PHP 5.3.6 MySQL 5.5.9
    Live: PHP 5.2.3 MySQL 4.1.22

    I thought that the PHP could be an issue, but it's the same release, different update... Could it be MySQL?

    I might try doing a fresh DB export and load, before I give the client access to make content....

    Not sure what else to try, can you direct me where the setting is stored for display on individual posts in the DB perhaps I can go in and edit that directly in the DB?

    Kind Regards, Emma.

  6. emma.echter
    Member
    Posted 1 year ago #

    Hi, Have tried editing the DB of Dynamic Widgets > the line;

    widget-it = (chosen menu), maintype = single, name = (empty), value = 0

    Both removing it and changing it to value=1, but the menu still will not appear.

    Do you think it might be the MySQL version?

    Thanks, Emma.

  7. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    No, I don't think the MySQL version difference can be the problem. It looks like for some reason the single posts page is not detected. What I can do for you is send you a special version of DW which has debugging enabled. That shows information about the processes DW is going through to detect the current page and which rules to apply.

    When you're interested, please send me an email via the contactform at my website. Please include the DW version you are using. I'll reply to you with the modified version attached and further instructions.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.