WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] .sql file created in wp_snapshots dir, but not log, package or installer (4 posts)

  1. i-Mobyl
    Member
    Posted 1 year ago #

    Seems people have Duplicator working on wp3.4.2, so the wp version likely not the issue?

    The system check passes, and when I create a package, the SQL file is created, but not the package or installer files. Neither is the log file (at least not in the wp-snapshots directory (though there are 2 php and a robots.txt file in it.) No messages appear. Dashboard shows package size as 0B.

    Any idea how to debug so as to determine the reason for the missing log file?

    Thanks!

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Its probably a permissions error. If you want to submit a support ticket I can work more closely with you on the issue.

    support.lifeinthegrid.com

  3. sjricha
    Member
    Posted 1 year ago #

    Hi,

    Did this issue get resolved at all? I have exactly the same problem. .sql file is created (150MB) but nothing showing in the "available packages".

    Thanks for any help. Oh and all of the server requirements are "passed".

    Strange one.

    Simon

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    I believe it ended up being a permission error I don't recall the users specific ticket. Usually there are two reasons why the process would not create the zip and installer files.

    1. Permissions. Check that the group/owner that the PHP process runs under has the necessary access to create certain file types. If the log file can't be created then PHP is having an issue writing to the server with the permissions that it is running under. Check with your host to validate that PHP can create .log and .zip files at the path you have your snapshots being created at...

    2. A server timeout. Some hosts only allow PHP processes to run for 30-60 seconds max. If this is the case and you have allot of files to archive then the PHP process will timeout before it can complete. To get around this you will need to check your hosting providers settings (usually in the php.ini file) and set the max timeout to something higher so the archive process can finish running...

    Hope that helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic