WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Duplicator
[resolved] [Plugin: Duplicator] Posts and Pages not displayed (Urgent timeframe) (8 posts)

  1. twarneke
    Member
    Posted 1 year ago #

    Duplicator Version 0.3.2 is shown in plugin list.

    I've used Duplicator to copy a WP site from my Dreamhost server tomwarneke.com to a new server instance on Amazon AWS EC2 with WordPress installed.

    This is a project for a college course on Cloud Computing that is due soon. For this project, I wanted to try out Duplicator to see if it could be used to clone a new WP site from an existing one.

    The EC2 Server is Microsoft Windows Server 2008 R2 with Server express and IIs. MySQL and WordPress were installed using installers provided by Amazon. I deleted the WP content in wwwroot, copied the Duplicator data and installer to the wwwroot directory and ran the Duplicator installer per instructions and allowed it to overwrite the MySQL tables. I deactivated/reactivated plugins, registered Jetpack, etc.

    Using MySql Workbench on the new AWS server, it appears that the tables are populated with the data extracted from the source on tomwarneke.com. The new site comes up with the basic format, but with no posts and no about pages, etc. displayed.

    Here are the source and new sites to compare:

    Source: http://www.tomwarneke.com/
    New AWS: http://54.243.190.86

    Any assistance is appreciated.
    Thank you!
    Tom
    [email address moderated - this forum does not provide support via email]

    http://wordpress.org/extend/plugins/duplicator/

  2. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    You can try a few things.

    1. Check the web.config file to make sure any permalink re-writes are correct. see the bottom section of this article for more links http://codex.wordpress.org/Installing_on_Microsoft_IIS the plugin doesn't support any updates to the web.config file only Apaches config files...

    2. Check the permissions on the content-*.php file that renders the blog content section to make sure php can read the file.

  3. twarneke
    Member
    Posted 1 year ago #

    Thank you for the advice! I'll look in to the items mentioned.
    - Tom

  4. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Forgot to ask, can you see the data in the wp-admin posts and pages editor ?

  5. twarneke
    Member
    Posted 1 year ago #

    Hi, Thank you for your help.

    I've abandoned the Windows server instance and created a Linux/Apache server. I have installed everything and run the installer from a newly generated Duplicator install set. The new site is at: http://54.243.190.86

    The front page looks good -- it shows the post previews, etc. and the about page links, but if I click on a page or post link I get the message, "The requested URL /college-textbook-discount/ was not found on this server." I can edit an old post. It appears that the host prefix is missing. I suspect this is an easy fix, but I don't know where to fix it. Any guidance is appreciated.

    Thank you!
    Tom

  6. twarneke
    Member
    Posted 1 year ago #

    Update...on http://54.243.190.86
    I've removed plugins "WordPress SEO" and "WP Super Cache" and set permalinks to "Standard". Everything works!

    But, if I change permalinks to "Post Name" (/%postname%/) it is broken again.

    I am narrowing in on the problem... any suggestions?
    Thank you,
    Tom

  7. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    You might want to checkout this article on the Codex:
    http://codex.wordpress.org/Using_Permalinks

  8. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Twarneke,

    Did you get these issues worked out?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic