WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Installer not restoring database (4 posts)

  1. EHRETic
    Member
    Posted 1 year ago #

    Hello,

    I've tried a few settings, but when I try to restore a complete package, it's not restoring database, despite correct connectivity and empty database. Here is the log for database :

    **********************************************************
    DATABASE-ROUTINES
    **********************************************************
    START-DB:02:47:08
    
    db create: false
    db clean: false
    db replace characters: false
    db mysqli charset: false
    db wait_timeout: 5000
    ----------------------------------
    DATABASE RESULTS
    processed queries: 12506
    process time: 0.0766 sec.
    
    Table Record Counts
    NOTICE: You may have to manually run the installer-data.sql to validate data input. Also check to make sure your installer file is correct and the
    			table prefix 'xxxxxx_' is correct for this particular version of WordPress. 
    
    Transient cached cleanup completed.
    
    ----------------------------------
    START SERIALIZATION:02:47:08
    
    serialization query ():
    SELECT option_id, option_value FROM xxxxxx_options 
    
    serialization query ():
    SELECT meta_id, meta_value FROM xxxxxx_postmeta 
    
    serialization query ():
    SELECT umeta_id, meta_value FROM xxxxxx_usermeta 
    
    serialization replacements:
    updated 0 records
    
    serialization replacements overview:
    
    END SERIALIZATION:02:47:08
    
    END DB-ROUTINES:02:47:08

    Of course, site seems to start from scratch and you have to start creating users, etc... empty site ! :-)

    Hope you can help ! ;-)

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey EHRETic,

    Did you check the install-data.sql file? If it's empty then its usually is related to a permissions error where PHP doesn't have enough permissions to copy the source from the database.sql file over to install-data.sql file when the files are extracted from the zip package...

    You may have to mess around with the permission settings on the root folder where you are trying to install from, also check the owner/group.

  3. EHRETic
    Member
    Posted 1 year ago #

    Hello,

    No no, in fact, file install-data.sql was not empty : I've used it to test it afterwards and it was restoring content (size 16MB approx.)

    But after that blog was not usable, it was making an error with Facebook AWD plugin... But that is another issue we ened to resolve after ! ^^

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    If you want to submit a support ticket I can take a deeper look into the issue for you...

    support.lifeinthegrid.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic