WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Duplicator
[resolved] [Plugin: Duplicator] Error 403 trying to run install.php - Windows hosting (15 posts)

  1. Jeff
    Member
    Posted 1 year ago #

    I am trying to create a test environment. I created a brand new sub-domain and website for it, copied the install.php and the ZIP over to the root of the site, and then browsed to /install.php and I get an error 403. Am I missing something? If it makes any difference, my hosting company is Arvixe.com.

    http://wordpress.org/extend/plugins/duplicator/

  2. Jeff
    Member
    Posted 1 year ago #

    Cancel this...it was incorrect permissions. I had to forcibly set the root permissions to re-inherit. Evidently the ZIP and install.php file permissions were copied from the site I am copying FROM. Great product!

  3. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Jeff,

    Good to know. In the upcoming versions I'm going to try to better alert on these types of issues.

    Thanks for the feedback!

  4. anotherwpdev
    Member
    Posted 1 year ago #

    Hey Jeff,
    I am having the same problem and am relatively new to OSX/BASH
    How do I "forcibly set the root permissions to re-inherit." ?

    Thanks!

  5. Jeff
    Member
    Posted 1 year ago #

    In my Hosting company I just ticked a permissions option to re-inherit in the cPanel. However, for Linux/Bash/OSX, you will probably need to use:
    chmod -R XXX (for whatever permissions level you want).

    -R will Recursively go through all subdirectories/files and set the same permissions.

  6. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    There is a video at the bottom of the User Guide that covers similar concepts for Linux systems...

  7. anotherwpdev
    Member
    Posted 1 year ago #

    This is for a local environment to develop a theme...
    very strange - I am able to access installer.php no problem so I think my apache settings are correct. I then use phpmyadmin to create a database, root has all privileges, it runs correctly and then I get this:

    You don't have permission to access /installer.php on this server.

    Any ideas?

  8. anotherwpdev
    Member
    Posted 1 year ago #

    I suppose I could create a test subdomain on the remote hosting provider and use cPanel as described but would rather be able to develop locally.

  9. anotherwpdev
    Member
    Posted 1 year ago #

    the 403 happens after I click Run Deployment...

  10. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    It probably an Apache directive that needs to be set... Googleing for: "You don't have permission to access this server Apache" has some pretty good feeds... Here is one that looks promising:

    http://stackoverflow.com/questions/10873295/forbidden-you-dont-have-permission-to-access-on-this-server

    Hope that helps!

  11. panuma
    Member
    Posted 11 months ago #

    Hi lifeinthegrid!

    I just transferred a site on another server but when I click on "save permalinks" I get 403 forbidden error.
    I've been reading it could be .htaccess issue (but the same site with same file is running on another server right now), or file permissions but directories are set to 705 and files 644..

    any idea? thanks in advance

    http://www.j-ose.com

  12. Jeff
    Member
    Posted 11 months ago #

    Try 755 temporarily at the root and have it set as -R (chmod -R 755 /). Once it is complete, you can more directly lock down permissions after it is up and running.

  13. panuma
    Member
    Posted 11 months ago #

    thanks for you reply Jeff.
    I've set all folders to 755, but I still get 403.

  14. panuma
    Member
    Posted 11 months ago #

    thanks for you reply Jeff!
    It was my server's firewall that was blocking access.

  15. lifeinthegrid
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks for posting your solutions!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic