WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Duplicator
[resolved] [Plugin: Duplicator] Drops links to avatars (8 posts)

  1. audiferd
    Member
    Posted 1 year ago #

    Duplicator works almost perfectly in transferring from one site to another, including (as we now know) locally hosted servers such as WAMP and XAMPP. Almost.

    The only thing that seems to fail is the linking to avatar images. I tried it with the most popular avatar plugins that allow for adding local (private) avatars, such as Simple Local Avatars, Add Local Avatar and User Avatar, meant for users who don't use Gravatar. In all cases, regardless of the site being hosted online or a local server, avatars that were showing up properly on the original site default to the Gravatar mystery man even though the image is available on site.

    Any ideas?

    http://wordpress.org/extend/plugins/duplicator/

  2. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Hi audiferd,

    It might be with how the settings are saved with those plugins. I'll add this to the todo list of items to research and check.

    Thanks for the feedback!

  3. supersuphot
    Member
    Posted 1 year ago #

    Mine too, I think it happen because of serialized PHP strings (in the database)
    like change domain name with different length (s:21:"http://www.domain.com";) will cause serialized strings error

    Suggestion:
    http://interconnectit.com/124/search-and-replace-for-wordpress-databases/

  4. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Hey supersuphot,

    Duplicator 0.2.9 should handle normal serialization. However it doesn't handle base64 encoded strings that are serialized. In version 0.3.0 this has been added and should be available in the next few weeks.

    Hope this helps!

  5. supersuphot
    Member
    Posted 1 year ago #

    Awesome!! Thanks lifeinthegrid.

  6. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    No Problem! Let me know if you run into any issues when it come available. Thxs again for the feedback!

  7. audiferd
    Member
    Posted 1 year ago #

    Just upgraded to 0.3.1. This issue is definitely resolved.

    Thanks again.

  8. lifeinthegrid
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome! The only plugin that I actually did a full test on was Simple Local Avatars, but I believe the rest work the same so we should be good to go...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic