WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Doesn't seem to work with Wampserver (6 posts)

  1. audiferd
    Member
    Posted 2 years ago #

    Love the concept. But it doesn't seem to work properly using Wampserver. I installed a package on my localhost and the home page shows up just fine. However the links to any posts or pages resulted in 404 errors even though the URLs were correct.

    To rule out if the problem was caused by the website I was packaging, I did a fresh WordPress install, packaged and installed it on the localhost and got the same result.

    Any ideas?

    Thanks

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 2 years ago #

    Hey audiferd,

    It could be related to the .htaccess file. Did you rule out any of these issues other users found on similar threads?

    http://wordpress.org/support/topic/pls-help-all-pages-except-homepage-404-error?replies=8

    http://wordpress.org/support/topic/help-every-page-except-home-page-became-a-404-error?replies=6

    Let me know how it goes.

  3. audiferd
    Member
    Posted 2 years ago #

    Well, I figured it out. I ruled out the issues mentioned in the links you provided (thanks).It wasn't about permalinks or the .htaccess file - those were all just fine. I found the solution deep in http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks.

    About halfway down the page I found this:

    Users of WAMP (Windows): Some versions of WAMP (all versions?) do not enable mod_rewrite or permit following SymLinks by default. To enable the required functionality navigate to the apache/conf/httpd.conf file, open with a text editor and uncomment the line LoadModule rewrite_module modules/mod_rewrite.so (i.e., delete the hash/pound sign at the front of the line). Then further down in the same file there is a section that starts with the line "Options FollowSymlinks". Change the second line in that section from "AllowOverride none" to AllowOverride all. Save edited httpd.conf and restart all WAMP modules. Your permalinks should now work.

    The part I bolded and italicized did it!

    Thanks for a great plugin!!

  4. Cory Lamle
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for posting the fix and helping out the rest of the community.

    Good Find!

  5. stillinbeta
    Member
    Posted 2 years ago #

    Thank you for the info audiferd, I was having the same problem. Fixed now! =]

    Thank you lifeinthegrind for the excellent plugin!

  6. Cory Lamle
    Member
    Plugin Author

    Posted 2 years ago #

    No Problem! Thanks again to audiferd for sharing the workaround, its nice when people help give back to the community!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic