WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] "A configuration file already exists in this location" Install Error (10 posts)

  1. dorearendil
    Member
    Posted 1 year ago #

    Hi again!

    I uploaded the package and install to an empty directory on my server, and created a new DB for the occasion.

    But when launching the install process, a few seconds later I got an error screen telling me:

    INSTALL ERROR!
    A configuration file already exists in this location. You have two options:

    Empty this root directory and recopy the package and installer.
    Copy package from "wp-snapshots" directory back up to your root (same location as installer.php) and delete the wp-config.php file.

    This is weird, of course, since the directory was empty to start with.

    Opening that directory, I can see the installer unpackaged pretty much everything, as far as I can tell (I didn't count all files of check every directory) -- EXCEPT for the "wp-snapshots" folder, which only contains an index.php file.

    In my database, the tables were created, but are all empty (no posts content, etc). Unsurprisingly, I get an "Error Establishing Database Connexion" when trying to access the directory with a browser.

    The installer-log.txt file is blank.

    Any thoughts?
    Best,
    Dorian

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Humm that is strange, never had anyone report that issue. What version of PHP/MySQL are you using? Do you happen to have open php open_basedir (check your php.ini file)?

    You might also check the permissions and owner/group of the directory you trying to deploy the package on. You can temporarily try 777 to see if gets things going...

  3. dorearendil
    Member
    Posted 1 year ago #

    "open_basedir" doesn't appear in my php.ini file (set to "no value" in phpinfo).

    Permissions seem to be alright...

    I tried the same install on a different server, and this time the problem is slightly different: I actually get the "Install Complete" screen, but upon trying to access wp-admin, a message tells me the database needs to be repaired. I repair it, all tables seem to be OK. But still the message occurs, so I visit the DB through PHPmyAdmin, and discover that, once more, all tables exist but all are full of zeros...

    Actually I just read on the Duplicator FAQs about something that may be causing mayhem (?): the fact that half of my site is in Chinese, and that I should have therefore unchecked the "Enable character conversion encoding" option when creating my package...
    Do you think this could be the culprit?

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Dorearendil,

    If you have international characters they you will want to uncheck the "Enable Character conversion" in the options dialog, and then at install time you will need to check the 'Enable MySQL character set'. That might be your issue...

  5. dorearendil
    Member
    Posted 1 year ago #

    Yes, I think that was probably the problem.
    I'll see if this fixes it next time I try the install.
    Thanks for your support.

  6. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Dorearendil,

    Any luck with this?

  7. dorearendil
    Member
    Posted 1 year ago #

    Hey man,
    I'm on a trip currently, terribly slow Internet connexion -- I'll try again in about a week when I'm back home, and will let you know.
    Thanks for your help.
    Cheers,
    D-

  8. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Any update on this one?

  9. mr.Karl
    Member
    Posted 1 year ago #

    I am having the same drama, and having used several different migrating tools to try and get this to work, the best luck I have had is that it installs a clean version of WP but with none of the local server development (no site, graphics etc.). FWIW I suspect that it may have something to do with it being a windows server that I am migrating to.

    Look forward to any updates....

  10. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Mr.Karl,

    You can try the latest version (0.4.0) it may have your fixes for the issue your seeing. The very latest version can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one

    Let me know if that helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic